Replying to PMs from OpenID users should Just Work but Really Doesn't #1744

Closed
kaberett opened this Issue Apr 11, 2016 · 0 comments

Comments

Projects
None yet
3 participants
@kaberett
Member

kaberett commented Apr 11, 2016

http://www.dreamwidth.org/support/see_request?id=33116

Hello, I recently got a message from someone via their wordpress openID. When I try replying from the inbox page, when I hit the send button it complains about their wordpress url not being a valid user name.

I did manage to send a reply by using the link in the email I received about the message (which uses their 'ext_9999' identifier rather than their wordpress url as the "name"). But I thought I should still send this report so y'all are aware of the inconsistency/bugginess.

Hitting Reply from the Inbox page should, in fact, automagically map to the ext_XXXX username, without the user having to apply workarounds.
#1691, #1615, and #303 might be useful to look at for guidance!

@kareila kareila self-assigned this Feb 4, 2017

kareila added a commit to kareila/dw-free that referenced this issue Feb 4, 2017

[#1744] use username, not display_name, in msg_to
This allows the message to be delivered successfully
when replying to a PM from an OpenID user.

Fixes #1744.

@kareila kareila referenced this issue Feb 4, 2017

Merged

OpenID fixes #1956

@zorkian zorkian closed this in #1956 Feb 12, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment