Installing chiton problems #4

Closed
goody44 opened this Issue Jul 28, 2010 · 6 comments

Comments

Projects
None yet
2 participants

goody44 commented Jul 28, 2010

Hi, I'm trying to install chiton and I've installed all of the necessary libraries but its throwing an error when I try to run it. The error is:

from: can't read /var/mail/twisted.internet
bash: bin/chiton-client: line 4: syntax error near unexpected token from' bash: bin/chiton-client: line 4:from twisted.internet import reactor'

Anyone got any ideas as to what might be causing this?
Thanks

Owner

driftx commented Jul 29, 2010

Somehow, the shebang in bin/chiton-client isn't being executed, and instead bash is executing 'from' which is why it's giving you the /var/mail/twisted.internet error. I'm not sure how this can happen, clearly the first line of bin/chiton-client is #!/usr/bin/env python

goody44 commented Jul 29, 2010

Thanks for the reply!
Nah the first line is being executed. Sorry I hould of posted what I was calling. Ant other ideas?
engineer@engineer-desktop:~/Downloads/driftx-chiton-bd91965$ . bin/chiton-client
from: can't read /var/mail/twisted.internet
bash: bin/chiton-client: line 4: syntax error near unexpected token from' bash: bin/chiton-client: line 4:from twisted.internet import reactor'

Owner

driftx commented Jul 29, 2010

A dot in bash is equivalent to the bash internal 'source' command, so it's trying to source the python code as shell script. Try 'bin/chiton-client' instead.

goody44 commented Jul 29, 2010

Thanks that gave me a more promising output
engineer@engineer-desktop:~/Downloads/driftx-chiton-bd91965$ bin/chiton-client
Traceback (most recent call last):
File "bin/chiton-client", line 6, in
from chiton.viewer import ChitonViewer
ImportError: No module named chiton.viewer

Owner

driftx commented Jul 29, 2010

Now you seem to have issues with PYTHONPATH. Try 'export PYTHONPATH=~/Downloads/driftx-chiton-bd91965:/path/to/telephus'

goody44 commented Jul 29, 2010

I finally got it working! The problem was the post above along with various things that we're installed properly. Thanks for your help!

This issue was closed.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment