Permalink
Browse files

assume active_support 3.0.0 for these snippets

  • Loading branch information...
drnic committed Oct 10, 2010
1 parent 7d84944 commit c99e35378171f64c530047f210ce4c77cbe7eb35
Showing with 3 additions and 1 deletion.
  1. +1 −0 Snippets/class .. end (cla).plist
  2. +2 −1 Snippets/module .. end.plist
@@ -6,6 +6,7 @@
<string>class ${1:`#!/usr/bin/env ruby
require 'rubygems'
require "active_support"
+ require 'active_support/core_ext/string'
puts (ENV['TM_FILENAME'] || 'some_model.rb').gsub(/\.rb$/, '').camelize.singularize
`}
$0
@@ -5,7 +5,8 @@
<key>content</key>
<string>module ${1:`#!/usr/bin/env ruby
require 'rubygems'
- require "active_support"
+ require 'active_support'
+ require 'active_support/core_ext/string'
puts (ENV['TM_FILENAME'] || 'some_model.rb').gsub(/\.rb$/, '').camelize.singularize
`}
$0

0 comments on commit c99e353

Please sign in to comment.