Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Does this library use Dropbox API v2? #49

Closed
fniephaus opened this issue Jun 28, 2016 · 14 comments
Closed

Does this library use Dropbox API v2? #49

fniephaus opened this issue Jun 28, 2016 · 14 comments

Comments

@fniephaus
Copy link

@fniephaus fniephaus commented Jun 28, 2016

Skimming over the code suggests otherwise. No mentioning of v2 at all.

Referring to this blog post, there isn't a guideline for migrating to v2 in PHP yet.

@cakoose

This comment has been minimized.

Copy link
Contributor

@cakoose cakoose commented Jun 28, 2016

This SDK uses v1.

The end of the blog post says that migration instructions for PHP will be added before v1 is retired.

@fniephaus

This comment has been minimized.

Copy link
Author

@fniephaus fniephaus commented Jun 28, 2016

Thanks!

@fniephaus fniephaus closed this Jun 28, 2016
@jonrcable

This comment has been minimized.

Copy link

@jonrcable jonrcable commented Jun 29, 2016

are there any plans to update this package to v2?

@greg-db

This comment has been minimized.

Copy link

@greg-db greg-db commented Jun 29, 2016

No, unfortunately we don't currently have plans for an official PHP SDK for Dropbox API v2.

@fniephaus fniephaus reopened this Jun 29, 2016
@fniephaus

This comment has been minimized.

Copy link
Author

@fniephaus fniephaus commented Jun 29, 2016

So how are we supposed to migrate to v2 then? Will Dropbox recommend a third party library instead?

@greg-db

This comment has been minimized.

Copy link

@greg-db greg-db commented Jun 29, 2016

You can use the HTTPS endpoints directly or use a third party library. We can't officially endorse any third party libraries in particular, but we are listing them here. There isn't currently one for PHP listed, but I am aware of this one.

@fniephaus

This comment has been minimized.

Copy link
Author

@fniephaus fniephaus commented Jun 29, 2016

Thanks, please keep us posted if possible!

@kunalvarma05

This comment has been minimized.

Copy link

@kunalvarma05 kunalvarma05 commented Jun 30, 2016

@greg-db @fniephaus Mind giving this a try? Actively working on it. Well documented. Has API Docs.

@megaspy

This comment has been minimized.

Copy link

@megaspy megaspy commented Jul 16, 2016

This is so disappointing... I have a lot of code with this library and using any different library means that I will have to change all the code...
Maybe someone changed the v1 library ? Or does anyone know any solution with the same interface?

@minkbear

This comment has been minimized.

Copy link

@minkbear minkbear commented Aug 22, 2016

got a reminder from dropbox

On June 28, 2017, API v1 will be turned off.

As a reminder, you need to sign in to the Dropbox developers site by September 28, 2016, and acknowledge that you’re aware of this change.

ref: https://blogs.dropbox.com/developers/2016/06/api-v1-deprecated/

@freekmurze

This comment has been minimized.

Copy link

@freekmurze freekmurze commented Apr 21, 2017

I've created a PHP SDK that uses v2 of the API.

https://github.com/spatie/dropbox-api

I'm accepting PRs that adds more endpoints to the package.

@donriga

This comment has been minimized.

Copy link

@donriga donriga commented Sep 30, 2017

HTTP status 400 {"error": "v1_retired"}

@greg-db

This comment has been minimized.

Copy link

@greg-db greg-db commented Oct 2, 2017

@donriga Per the API v1 deprecation timeline, API v1 has now been retired. This SDK does use API v1, so if you make any more API v1 calls with it, they will fail with that error. If you need more time to migrate your app to API v2, we can offer an extension for access to API v1. To request that, please open an API ticket with the relevant app key(s).

We don't have plans for an official PHP SDK for Dropbox API v2, but you can use a third party library, or you can call the HTTPS endpoints themselves.

@greg-db greg-db closed this Oct 2, 2017
@donriga

This comment has been minimized.

Copy link

@donriga donriga commented Oct 2, 2017

I use another library for my problem
https://github.com/kunalvarma05/dropbox-php-sdk

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
9 participants
You can’t perform that action at this time.