Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update jackson version to 2.9.10 #2939

Merged
merged 1 commit into from Sep 23, 2019

Conversation

@msymons
Copy link
Contributor

commented Sep 23, 2019

Problem:

As per #2938, jackson 2.9.9.20190807 has two newly-discovered threats: CVE-2019-14540 and CVE-2019-16335

Solution:

Bump jackson.version to 2.9.10

Update jackson.version from 2.9.9.20190807 to 2.9.10
This addresses threats CVE-2019-14540 and CVE-2019-16335
@jplock
jplock approved these changes Sep 23, 2019
@jplock jplock merged commit 2ca34d3 into dropwizard:release/1.3.x Sep 23, 2019
3 checks passed
3 checks passed
ci/circleci Your tests passed on CircleCI!
Details
continuous-integration/appveyor/pr AppVeyor build succeeded
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details
@joschi joschi added this to the 1.3.15 milestone Sep 23, 2019
@joschi joschi added the improvement label Sep 23, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.