Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update to make plugin work with GoCD 17.1 and above #3

Open
wants to merge 2 commits into
base: master
from

Conversation

Projects
None yet
1 participant
@arvindsv
Copy link

commented Dec 19, 2016

Using the plugin shim to upgrade this plugin, so that it works with 17.1. Without this change, this plugin will stop working from GoCD 17.1 onwards.

arvindsv added some commits Dec 8, 2016

Don't need to download deps any more
They're all in Maven central
@arvindsv

This comment has been minimized.

Copy link
Author

commented Dec 19, 2016

The configuration I used to verify this change is:

<repository id="bff28240-9028-4a85-a2f0-322bc0d06cd8" name="puppet-test">
  <pluginConfiguration id="puppetforge" version="1" />
  <configuration>
    <property>
      <key>FORGE_URL</key>
      <value>https://forge.puppet.com</value>
    </property>
  </configuration>
  <packages>
    <package id="5532775c-b9a2-473c-bb04-54008612e627" name="test-pkg">
      <configuration>
        <property>
          <key>MODULE_NAME</key>
          <value>puppetlabs/azure</value>
        </property>
      </configuration>
    </package>
  </packages>
</repository>
@arvindsv

This comment has been minimized.

Copy link
Author

commented Dec 19, 2016

Hmm. The build failed, because download-dependencies.rb does not exist any more. The travis YML has to change.

@arvindsv arvindsv changed the title Make this plugin work with GoCD 17.1 and above Update to make plugin work with GoCD 17.1 and above Dec 20, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.