Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update composer.json to require latest stable version of Drupal #424

Merged
merged 3 commits into from Sep 6, 2018

Conversation

Projects
None yet
5 participants
@grasmash
Copy link
Contributor

commented Sep 5, 2018

I'd like to post the following instructions on the /download page on Drupal.org:

composer create-project drupal-composer/drupal-project:8.x-dev --stability dev --no-interaction

However, this will require drupal-project to provide the latest recommended version of Drupal so that it matches the download button.

Update composer.json
I'd like to post the following instructions on the /download page on Drupal.org:

    composer create-project drupal-composer/drupal-project:8.x-dev --stability dev --no-interaction

However, this will require drupal-project to provide the latest recommended version of Drupal so that it matches the download button.

@grasmash grasmash changed the title Update composer.json Update composer.json to require latest stable version of Drupal Sep 5, 2018

@greg-1-anderson

This comment has been minimized.

Copy link
Collaborator

commented Sep 5, 2018

I agree that this is preferable. composer update should track the latest stable Drupal version by default.

@webflo webflo referenced this pull request Sep 6, 2018

Closed

Drupal 8.6 update #426

@webflo webflo merged commit c1e2b6e into drupal-composer:8.x Sep 6, 2018

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
@hansfn

This comment has been minimized.

Copy link
Contributor

commented Sep 7, 2018

Maybe we should documented somewhere that drupal-composer/drupal-project no longer is locked to a specific minor version since we have replaced "drupal/core": "~x.y.z" with "drupal/core": "^x.y.z"

More importantly, it should be mentioned in the update section that people with existing projects have to make this change to drupal/core and webflo/drupal-core-require-dev manually.

@jonpugh

This comment has been minimized.

Copy link

commented Sep 7, 2018

Note I submitted a PR to the README.md related to this... #423

daften added a commit to digipolisgent/drupal8_project_template that referenced this pull request Sep 10, 2018

Merge branch '8.x' of github.com:drupal-composer/drupal-project into …
…8.x-upstream

* '8.x' of github.com:drupal-composer/drupal-project:
  Update composer.json to require latest stable version of Drupal (drupal-composer#424)
  Bump minimum required composer-patches version to support default patch level (drupal-composer#410)
  Adjust default core patch level to -p2. (drupal-composer#418)

# Conflicts:
#	composer.json

Natkeeran added a commit to Islandora-CLAW/drupal-project that referenced this pull request Sep 17, 2018

Drupal 8.6 (#23)
* Honor .env files and suggest usage (drupal-composer#351)

* Remove extra whitespace (drupal-composer#371)

* Updated argument name

* Bump minimal version

* Bump minimal version to 8.5.3

* Fix installer path for drush commandfiles.

* Update drupal-composer/drupal-scaffold

drupal-composer/drupal-scaffold is a full featured plugin and provides its own command.

* Fix tests on Travis CI (drupal-composer#405)

* Copy the editor config and gitattributes from drupal to the root. (drupal-composer#404)

* Remove "drupal-scaffold" from scripts (drupal-composer#275)

* Fix typo in README.md

* Remove unused use statement. (drupal-composer#406)

* Adjust default core patch level to -p2. (drupal-composer#418)

* Bump minimum required composer-patches version to support default patch level (drupal-composer#410)

* Update composer.json to require latest stable version of Drupal (drupal-composer#424)

* Updating lock file

* Adding drupal-scaffold back in so it works with a lockfile

* drupal-scaffold is now @composer drupal:scaffold

whikloj added a commit to Islandora-CLAW/drupal-project that referenced this pull request May 24, 2019

Drupal 8.7 (#27)
* Honor .env files and suggest usage (drupal-composer#351)

* Remove extra whitespace (drupal-composer#371)

* Updated argument name

* Bump minimal version

* Bump minimal version to 8.5.3

* Fix installer path for drush commandfiles.

* Update drupal-composer/drupal-scaffold

drupal-composer/drupal-scaffold is a full featured plugin and provides its own command.

* Fix tests on Travis CI (drupal-composer#405)

* Copy the editor config and gitattributes from drupal to the root. (drupal-composer#404)

* Remove "drupal-scaffold" from scripts (drupal-composer#275)

* Fix typo in README.md

* Remove unused use statement. (drupal-composer#406)

* Adjust default core patch level to -p2. (drupal-composer#418)

* Bump minimum required composer-patches version to support default patch level (drupal-composer#410)

* Update composer.json to require latest stable version of Drupal (drupal-composer#424)

* Require zaporylie/composer-drupal-optimizations (drupal-composer#442)

* Issue drupal-composer#408: Bump minimum PHP version to 5.6

* Removing redundant "--stability dev" from installation command (drupal-composer#450)

Fixes drupal-composer#449.

* Added "composer-exit-on-patch-failure": true option to composer.json (drupal-composer#420)

* Sync new lines at the end of the files (drupal-composer#453)

* Quote wildcards to avoid issues in some shells (drupal-composer#456)

* Add PHP 7.3 to Travis CI (drupal-composer#476)

* Change createRequiredFiles messages to reflect what occured (drupal-composer#467)

* Drop PHP 5.6 testing (drupal-composer#489)

* Bump minimum version to 8.7.0 (drupal-composer#488)

* Update .travis.yml

* update composer.lock
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.