Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Add version (release, tag) from Git to Docker Tag #54

Closed
zaporylie opened this issue Sep 13, 2016 · 1 comment
Closed

Add version (release, tag) from Git to Docker Tag #54

zaporylie opened this issue Sep 13, 2016 · 1 comment
Labels
Milestone

Comments

@zaporylie
Copy link
Member

@zaporylie zaporylie commented Sep 13, 2016

I think we should start versioning our collection of docker images to allow, at some point, major (breaking) changes.

Initial release could look like this:

PHP version Type Docker Tag (current) Docker Tags (new) Git Tag
5.4 cli 5.4-cli 5.4-cli, 5.4-cli-1.0.0, 5.4-cli-1.0, 5.4-cli-1 1.0.0
5.4 fpm 5.4-fpm 5.4-fpm, 5.4-fpm-1.0.0, 5.4-fpm-1.0, 5.4-fpm-1 1.0.0
5.4 apache 5.4-apache 5.4-apache, 5.4-apache-1.0.0, 5.4-apache-1.0, 5.4-apache-1 1.0.0
5.5 cli 5.5-cli 5.5-cli, 5.5-cli-1.0.0, 5.5-cli-1.0, 5.5-cli-1 1.0.0
5.5 fpm 5.5-fpm 5.5-fpm, 5.5-fpm-1.0.0, 5.5-fpm-1.0, 5.5-fpm-1 1.0.0
5.5 apache 5.5-apache 5.5-apache, 5.5-apache-1.0.0, 5.5-apache-1.0, 5.5-apache-1 1.0.0
5.6 cli 5.6-cli 5.6-cli, 5.6-cli-1.0.0, 5.6-cli-1.0, 5.6-cli-1 1.0.0
5.6 fpm 5.6-fpm 5.6-fpm, 5.6-fpm-1.0.0, 5.6-fpm-1.0, 5.6-fpm-1 1.0.0
5.6 apache 5.6-apache 5.6-apache, 5.6-apache-1.0.0, 5.6-apache-1.0, 5.6-apache-1 1.0.0
7.0 cli 7.0-cli 7.0-cli, 7.0-cli-1.0.0, 7.0-cli-1.0, 7.0-cli-1 1.0.0
7.0 fpm 7.0-fpm 7.0-fpm, 7.0-fpm-1.0.0, 7.0-fpm-1.0, 7.0-fpm-1 1.0.0
7.0 apache 7.0-apache 7.0-apache, 7.0-apache-1.0.0, 7.0-apache-1.0, 7.0-apache-1 1.0.0

This way we could let people lock on specific release of drupal-docker/php. Of course additional tags (i.e. latest, 5, 7-cli) would still point to latest release within php branch.

@zaporylie zaporylie added the docs label Sep 13, 2016
@zaporylie zaporylie added this to the 1.0.0 milestone Sep 13, 2016
@zaporylie
Copy link
Member Author

@zaporylie zaporylie commented Dec 12, 2016

Tomorrow is the last day 5.4 and 5.5 are supported. I'm gonna add this policy to drupal-docker docs and setup releases on docker hub, to have at least one release of both 5.4 and 5.5 before end of tomorrow.

@zaporylie zaporylie closed this Dec 15, 2016
@zaporylie zaporylie mentioned this issue Nov 17, 2017
2 of 6 tasks complete
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant