New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Old versions of drush should help those moving to Drupal 8 find the new version of drush. #266

Closed
sumeetpareek opened this Issue Nov 15, 2013 · 2 comments

Comments

Projects
None yet
2 participants
@sumeetpareek

sumeetpareek commented Nov 15, 2013

Currently when somebody using version 5 of drush tries to use it in a drupal 8 site, they see the below message -

$ drush status
Drush 5.0-dev does not support Drupal . Use Drush 4 instead. 

I could be wrong, but a lot of drupal developers out there might not know that Drupal 8 sites work with the latest drush versions. How about putting in a more detailed error message in this scenario. Or better/simpler yet, update drush's project page on d.o. telling users to upgrade to drush 7 for it to work with drupal 8 installs here - https://drupal.org/project/drush

@weitzman

This comment has been minimized.

Show comment
Hide comment
@weitzman

weitzman Nov 15, 2013

Member

There is already a table on our Github page which shows this information. See README.md

What version of Drush5 are you using? Run drush --version. The message you quote is bug that might have been fixed in latest version but very few folks are going to upgrade to 5.11 at this point so I am not too motivated to fix it if the bug is still outstanding. Patches welcome .

Member

weitzman commented Nov 15, 2013

There is already a table on our Github page which shows this information. See README.md

What version of Drush5 are you using? Run drush --version. The message you quote is bug that might have been fixed in latest version but very few folks are going to upgrade to 5.11 at this point so I am not too motivated to fix it if the bug is still outstanding. Patches welcome .

@sumeetpareek

This comment has been minimized.

Show comment
Hide comment
@sumeetpareek

sumeetpareek Nov 15, 2013

Fair enough :-) I agree, fixing this with a patch would not be useful
actually.

I was on drush version 5.0-dev when I had seen the error. I am now of
course on 7.x-dev

On Fri, Nov 15, 2013 at 7:39 PM, Moshe Weitzman notifications@github.comwrote:

There is already a table on our Github page which shows this information.
See README.md

What version of Drush5 are you using? Run drush --version. The message
you quote is bug that might have been fixed in latest version but very few
folks are going to upgrade to 5.11 at this point so I am not too motivated
to fix it if the bug is still outstanding. Patches welcome .


Reply to this email directly or view it on GitHubhttps://github.com//issues/266#issuecomment-28571077
.

Sumeet Pareek

sumeetpareek commented Nov 15, 2013

Fair enough :-) I agree, fixing this with a patch would not be useful
actually.

I was on drush version 5.0-dev when I had seen the error. I am now of
course on 7.x-dev

On Fri, Nov 15, 2013 at 7:39 PM, Moshe Weitzman notifications@github.comwrote:

There is already a table on our Github page which shows this information.
See README.md

What version of Drush5 are you using? Run drush --version. The message
you quote is bug that might have been fixed in latest version but very few
folks are going to upgrade to 5.11 at this point so I am not too motivated
to fix it if the bug is still outstanding. Patches welcome .


Reply to this email directly or view it on GitHubhttps://github.com//issues/266#issuecomment-28571077
.

Sumeet Pareek

@weitzman weitzman closed this Nov 15, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment