Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Extension to Ruby geometry libraries
Ruby
branch: master
Failed to load latest commit information.
lib
spec Replace mock by double and delete gems not used in bundler
travis Complete doc and update travis config to test more ruby environment
.gitignore First merge of all our code
.travis.yml Fix number of travis build for each versions
Gemfile Fix some spec and update travis config
Guardfile Refactor for rgeo lib
LICENSE.md Complete doc and update travis config to test more ruby environment
README.md Remove compatibility for ruby 1.8.7
Rakefile First merge of all our code
georuby-ext.gemspec Bump to version 0.0.5

README.md

Georuby-ext Build Status Dependency Status Code Climate

Georuby-ext allows to use ruby geometry libraries together. It includes :

  • Rgeo
  • GeoRuby
  • Geokit
  • Proj4j

Requirements

This code has been run and tested on Travis with :

  • Ruby 1.9.3
  • Ruby 2.0
  • JRuby 1.7.2 (jruby-18mode, jruby-19mode) with oraclejdk7, openjdk7, openjdk6

External Deps

On Debian/Ubuntu/Kubuntu OS :

sudo apt-get install libproj-dev libgeos-dev libffi-dev

Installation

Without bundler : gem install georuby-ext

With bundler add to your Gemfile : gem 'georuby-ext', '>=0.0.2'

Test

bundle exec rake spec

More Information

More information can be found on the project website on GitHub. There is extensive usage documentation available on the wiki.

Example Usage

TODO ...

License

This project is licensed under the MIT license, a copy of which can be found in the LICENSE file.

Release Notes

The release notes can be found in CHANGELOG file

Support

Users looking for support should file an issue on the GitHub issue tracking page, or file a pull request if you have a fix available.

Something went wrong with that request. Please try again.