errs not in dependencies #70

Closed
nomiddlename opened this Issue May 15, 2012 · 3 comments

Projects

None yet

4 participants

@nomiddlename

Package.json has errs as dev dependency instead of dependency. Causes the following error on require('nano'):

require('nano')
Error: Cannot find module 'errs'
at Function._resolveFilename (module.js:332:11)
at Function._load (module.js:279:25)
at Module.require (module.js:354:17)
at require (module.js:370:17)
at Object. (/Volumes/MacHD2/verticals/cs-whereis-poi-extract/node_modules/nano/nano.js:21:19)
at Module._compile (module.js:441:26)
at Object..js (module.js:459:10)
at Module.load (module.js:348:31)
at Function._load (module.js:308:12)
at Module.require (module.js:354:17)

@thewongandonly

same here: [Error: Cannot find module 'errs']

@dscape dscape added a commit that closed this issue May 15, 2012
@dscape [fix] fixes #70 -- sorry guys 5b94fee
@dscape dscape closed this in 5b94fee May 15, 2012
@dscape
Owner

Thank you @nomiddlename and @thewongandonly

Travis.ci installs everything (including devDeps) so I didn't spot this.

It's fixed in nano@3.0.1

@samdutton

I got this for request, errs and underscore after installing nano 6.1.2.

(Odd – running `sudo npm install nano' again installed underscore.)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment