New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

3.1.0 problems #228

Closed
troutcolor opened this Issue Oct 14, 2018 · 30 comments

Comments

Projects
None yet
4 participants
@troutcolor

troutcolor commented Oct 14, 2018

Hi,
I updated johnjohnston.info/blog to use the 3.1.0 version of the plugin this morning. Lots of things broke. The WordPress json feeds for posts were empty (this was the first thing I noticed).

One reply post lost its response properties and visiting the category the post was it display that post and no others. It also showed up erroneously on the home page.
Other posts with Response Properties displayed some errors and posts were showing up in the wrong places. I turned on debugging and got this:
post_kinds-errors-14 Oct 2018.txt
in one post for example.
I've rolled back to 3.0.9 and most things seem ok.
Apologies for the rather sketchy report, but I didn't want to leave the site broken.

cheers

john

@mrkrndvs

This comment has been minimized.

mrkrndvs commented Oct 14, 2018

Like John, I too am having issues with Response Properties being striped out. I am wondering if it relates to particular kinds as this post worked find.

It also seems to have broken my bookmarklets generated using URL Forwarder.

Not sure if that helps, sorry.

Aaron

(Originally published at: https://collect.readwriterespond.com/post-kinds-3-1-0-problems/)

@dshanske

This comment has been minimized.

Owner

dshanske commented Oct 14, 2018

Roll back to 3.0.9. I did a lot of testing but clearly I missed something

@dshanske

This comment has been minimized.

Owner

dshanske commented Oct 14, 2018

@troutcolor You have Kind_Meta in your child theme. It was deprecated three versions ago and I removed the compatibility layer as promised in this version.

@dshanske

This comment has been minimized.

Owner

dshanske commented Oct 14, 2018

What information can you give me?

@dshanske

This comment has been minimized.

Owner

dshanske commented Oct 14, 2018

Since the breaking issue seems to be in code outside the plugin, you could bundle the Kind_Meta compatibility class or I could help you update the child theme.

@dshanske

This comment has been minimized.

Owner

dshanske commented Oct 14, 2018

@mrkrndvs Which properties?

@dshanske

This comment has been minimized.

Owner

dshanske commented Oct 14, 2018

Properties for audio, video, and photo posts are being relocated to the attachment.

@dshanske

This comment has been minimized.

Owner

dshanske commented Oct 14, 2018

@troutcolor Re the Jsonfeeds, what about them was empty?

@dshanske

This comment has been minimized.

Owner

dshanske commented Oct 14, 2018

I was told that the properties that I added to the feed were incorrect and I will be redoing them, but the feed itself should be fine.

@troutcolor

This comment has been minimized.

troutcolor commented Oct 14, 2018

Since the breaking issue seems to be in code outside the plugin, you could bundle the Kind_Meta compatibility class or I could help you update the child theme.

Thanks, I barely understand this!

I had copied a few kind_views into my child theme to customise them a bit. I guess I can look at the new version and copy the view from there? Or even the ones in 3.0.9?

@dshanske

This comment has been minimized.

Owner

dshanske commented Oct 14, 2018

Use the ones in 3.1.0

@troutcolor

This comment has been minimized.

troutcolor commented Oct 14, 2018

@troutcolor Re the Jsonfeeds, what about them was empty?

I just looked in the browser:
http://johnjohnston.info/blog/wp-json/wp/v2/
was fine but nothing showed, in the browser for
http://johnjohnston.info/blog/wp-json/wp/v2/posts

@troutcolor

This comment has been minimized.

troutcolor commented Oct 14, 2018

Use the ones in 3.1.0

Use the ones in 3.1.0

Thanks. I'll do that.

@dshanske

This comment has been minimized.

Owner

dshanske commented Oct 14, 2018

@troutcolor Basically, pulling in properties used to be in a class called Kind_Meta. I changed to MF2_Post last October.

@troutcolor

This comment has been minimized.

troutcolor commented Oct 14, 2018

@troutcolor Basically, pulling in properties used to be in a class called Kind_Meta. I changed to MF2_Post last October.

THanks.

So I renamed the kind_views folder in my child them and update the plugin again.

This has now stripped the response properties from posts.
The post now has "Replied to Array by an author" if I edit the post I see this:
screen shot 2018-10-14 at 17 57 32

This happened to one post the first time but seem to have happened to all the post on /blog my home page and
http://johnjohnston.info/blog/type/status/

which is a worry.

@dshanske

This comment has been minimized.

Owner

dshanske commented Oct 14, 2018

I agree. That did not happen in testing

@troutcolor

This comment has been minimized.

troutcolor commented Oct 14, 2018

I agree. That did not happen in testing

I am on PHP Version 5.3.19

I guess I'll roll back to 3.0.9 and then try to get the Responce properties back from a database back up?

@dshanske

This comment has been minimized.

Owner

dshanske commented Oct 14, 2018

Can you export some posts and send me the export file?

@dshanske

This comment has been minimized.

Owner

dshanske commented Oct 14, 2018

If you didn't update the posts, then it won't overwrite the data

@dshanske

This comment has been minimized.

Owner

dshanske commented Oct 14, 2018

I found an example of the an author issue.

@dshanske

This comment has been minimized.

Owner

dshanske commented Oct 14, 2018

Will release something before tomorrow to try and address

@dshanske

This comment has been minimized.

Owner

dshanske commented Oct 14, 2018

Array indicates that it didn't flatten properly. It is supposed to

@troutcolor

This comment has been minimized.

troutcolor commented Oct 14, 2018

Can you export some posts and send me the export file?

I couldn't upload xml file here so:
http://johnjohnston.info/john039sworldwidewalldisplay.wordpress.2018-10-14.xml

that might be too many. 2 months worth?

@dshanske

This comment has been minimized.

Owner

dshanske commented Oct 14, 2018

That's fine

@troutcolor

This comment has been minimized.

troutcolor commented Oct 14, 2018

If you didn't update the posts, then it won't overwrite the data

Thanks, I've just rolled back to 3.0.9 and all looks good. Appreciate all the fast support.

@dshanske

This comment has been minimized.

Owner

dshanske commented Oct 14, 2018

I hate when I miss something

@mrkrndvs

This comment has been minimized.

mrkrndvs commented Oct 14, 2018

@dshanske I wrote a post before updating and had it open in my browser. When I saved a draft it only left me with the URL property. I then tried to create a new post via my bookmarklet and it did that thing where it only loads the post properties box with no information. I then started a new bookmark and added the site into the properties box. Although it initially loaded all the information, when I previewed/posted it reverted back to just the URL.

I hope that helps. Thank you for all your work. Let me know if there are any other tests you would like me to do.

@dshanske

This comment has been minimized.

Owner

dshanske commented Oct 14, 2018

If you click into the url box and out it should load. Either way, will look at the auto

@stephenpieper

This comment has been minimized.

stephenpieper commented Oct 14, 2018

I'm getting the missing response properties on new posts only. eg "Bookmarked a post" with "a post" linked but no details at all. Old posts seem fine.

This is the only I error I have found. (Sempress theme).

@dshanske

This comment has been minimized.

Owner

dshanske commented Oct 15, 2018

I've identified 4 bugs and pushed out version 3.1.1 to address these bugs. One prevented, under certain circumstances, items from saving.

Will continue to do bugfixes as reported but these were critical for some.

@dshanske dshanske closed this Oct 15, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment