Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

* ruby 1.9.3-p374 - passenger

  • Loading branch information...
commit 3b7137920222898a1bd19275fc63fe237feadbeb 1 parent b274f6b
@dudemeister authored
Showing with 15 additions and 6 deletions.
  1. +3 −3 passenger.rb
  2. +12 −3 rvm.rb
View
6 passenger.rb
@@ -14,13 +14,13 @@
requires_when_unmet 'build tools', 'apache2 dev packages', 'libcurl4-openssl-dev.managed'
setup {
default_passenger_path = if Babushka::SystemProfile.for_host.name == :precise
- "/usr/local/rvm/gems/ruby-1.9.3-p125/gems/passenger-3.0.18"
+ "/usr/local/rvm/gems/ruby-1.9.3-p374/gems/passenger-3.0.18"
else
- "/usr/local/rvm/gems/ruby-1.9.3-p125/gems/passenger-3.0.12"
+ "/usr/local/rvm/gems/ruby-1.9.3-p374/gems/passenger-3.0.12"
end
passenger_path = Babushka::GemHelper.gem_path_for('passenger') || default_passenger_path
set :passenger_root, passenger_path
- set :ruby, "/usr/local/rvm/wrappers/ruby-1.9.3-p125/ruby"
+ set :ruby, "/usr/local/rvm/wrappers/ruby-1.9.3-p374/ruby"
}
met? {
View
15 rvm.rb
@@ -12,6 +12,15 @@ def rvm args
meet { sudo("/bin/bash", :input => 'rvm alias create default 1.9.3-p125', :su => true) }
end
+dep '1.9.3-p374.rvm' do
+ requires '1.9.3 installed.rvm'
+ met? {
+ login_shell('ruby --version') && login_shell('ruby --version')['ruby 1.9.3p374']
+ }
+ meet { sudo("/bin/bash", :input => 'rvm alias create default 1.9.3-p374', :su => true) }
+end
+
+
dep 'zlib.rvm' do
requires 'rvm'
met? {
@@ -35,11 +44,11 @@ def rvm args
dep '1.9.3 installed.rvm' do
requires 'rvm'
met? {
- rvm('list')['ruby-1.9.3-p125']
+ rvm('list')['ruby-1.9.3-p374']
}
meet {
- log('rvm install 1.9.3-p125'){
- sudo("/bin/bash", :input => 'rvm install 1.9.3-p125', :su => true)
+ log('rvm install 1.9.3-p374'){
+ sudo("/bin/bash", :input => 'rvm install 1.9.3-p374', :su => true)
}
}
after{
Please sign in to comment.
Something went wrong with that request. Please try again.