Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Mark & Comment out Ruby upgrade

  • Loading branch information...
commit 7204934de28b0e56123431c63f0289cffcaf9282 1 parent 91a0107
@leehambley leehambley authored
Showing with 53 additions and 45 deletions.
  1. +5 −5 passenger.rb
  2. +40 −32 ruby.rb
  3. +8 −8 rvm.rb
View
10 passenger.rb
@@ -1,7 +1,7 @@
# encoding: UTF-8
dep 'passenger' do
requires 'zlib headers.managed'
- met? {
+ met? {
which("passenger-install-apache2-module")
}
meet {
@@ -20,11 +20,11 @@
end
passenger_path = Babushka::GemHelper.gem_path_for('passenger') || default_passenger_path
set :passenger_root, passenger_path
- set :ruby, "/usr/local/rvm/wrappers/ruby-1.9.3-p374/ruby"
+ set :ruby, "/usr/local/rvm/wrappers/default/ruby"
}
met? {
- "#{var :passenger_root}/ext/apache2/mod_passenger.so".p.exists? && [
+ "#{var :passenger_root}/ext/apache2/mod_passenger.so".p.exists? && [
"mods-available/passenger.conf",
"mods-available/passenger.load"
].all? { |file|
@@ -57,11 +57,11 @@
dep 'passenger.deinstall' do
- met? {
+ met? {
!which("passenger-install-apache2-module")
}
meet {
sudo("gem uninstall -ax passenger", :as => 'protonet', :su => true)
}
-end
+end
View
72 ruby.rb
@@ -1,39 +1,47 @@
-dep 'ruby trunk.src' do
- requires 'bison.managed', 'readline headers.managed'
- source 'git://github.com/ruby/ruby.git'
- provides 'ruby == 1.9.3.dev', 'gem', 'irb'
-end
+#
+# The Rubies are installed with system-wide RVM now.
+#
-dep 'ruby19.src' do
- requires 'readline headers.managed'
- source 'ftp://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.2-p136.tar.gz'
- provides 'ruby == 1.9.2p136', 'gem', 'irb'
- configure_args '--disable-install-doc', '--with-readline-dir=/usr'
- # TODO: hack for ruby bug where bin/* aren't installed when the build path
- # contains a dot-dir.
- postinstall {
- shell "cp bin/* #{prefix / 'bin'}", :sudo => Babushka::SrcHelper.should_sudo?
- }
-end
+#dep 'ruby trunk.src' do
+# requires 'bison.managed', 'readline headers.managed'
+# source 'git://github.com/ruby/ruby.git'
+# provides 'ruby == 1.9.3.dev', 'gem', 'irb'
+#end
-dep 'ruby1.8-dev.managed' do
- provides []
-end
+#dep 'ruby19.src' do
+# requires 'readline headers.managed'
+# source 'ftp://ftp.ruby-lang.org/pub/ruby/1.9/ruby-1.9.2-p136.tar.gz'
+# provides 'ruby == 1.9.2p136', 'gem', 'irb'
+# configure_args '--disable-install-doc', '--with-readline-dir=/usr'
+# # TODO: hack for ruby bug where bin/* aren't installed when the build path
+# # contains a dot-dir.
+# postinstall {
+# shell "cp bin/* #{prefix / 'bin'}", :sudo => Babushka::SrcHelper.should_sudo?
+# }
+#end
-dep 'ruby18.src' do
- source 'ftp://ftp.ruby-lang.org/pub/ruby/1.8/ruby-1.8.7-p302.tar.gz'
- provides 'ruby18'
- configure_args '--program-suffix=18', '--enable-pthread'
-end
+#
+# Ruby 1.8 is already long past obsolete
+#
-dep 'rubygems18.src' do
- requires 'ruby18.src'
- provides 'gem18'
- source 'http://rubyforge.org/frs/download.php/70696/rubygems-1.3.7.tgz'
- process_source {
- sudo 'ruby18 setup.rb'
- }
-end
+#dep 'ruby1.8-dev.managed' do
+# provides []
+#end
+
+#dep 'ruby18.src' do
+# source 'ftp://ftp.ruby-lang.org/pub/ruby/1.8/ruby-1.8.7-p302.tar.gz'
+# provides 'ruby18'
+# configure_args '--program-suffix=18', '--enable-pthread'
+#end
+
+#dep 'rubygems18.src' do
+# requires 'ruby18.src'
+# provides 'gem18'
+# source 'http://rubyforge.org/frs/download.php/70696/rubygems-1.3.7.tgz'
+# process_source {
+# sudo 'ruby18 setup.rb'
+# }
+#end
dep 'ruby symlinked' do
define_var :ruby_version, :choices => %w[18 19]
View
16 rvm.rb
@@ -4,12 +4,12 @@ def rvm args
end
end
-dep '1.9.3-p125.rvm' do
+dep '1.9.3-p392.rvm' do
requires '1.9.3 installed.rvm'
- met? {
- login_shell('ruby --version') && login_shell('ruby --version')['ruby 1.9.3p125']
+ met? {
+ login_shell('ruby --version') && login_shell('ruby --version')['ruby 1.9.3p392']
}
- meet { sudo("/bin/bash", :input => 'rvm alias create default 1.9.3-p125', :su => true) }
+ meet { sudo("/bin/bash", :input => 'rvm alias create default 1.9.3-p392', :su => true) }
end
dep '1.9.3-p374.rvm' do
@@ -43,12 +43,12 @@ def rvm args
dep '1.9.3 installed.rvm' do
requires 'rvm'
- met? {
- rvm('list')['ruby-1.9.3-p374']
+ met? {
+ rvm('list')['ruby-1.9.3-p392']
}
meet {
- log('rvm install 1.9.3-p374'){
- sudo("/bin/bash", :input => 'rvm install 1.9.3-p374', :su => true)
+ log('rvm install 1.9.3-p392'){
+ sudo("/bin/bash", :input => 'rvm install 1.9.3-p392', :su => true)
}
}
after{
Please sign in to comment.
Something went wrong with that request. Please try again.