Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
tree: 3f93369a70
Fetching contributors…

Cannot retrieve contributors at this time

69 lines (45 sloc) 2.026 kb

Installation

Prerequisites

The program is implemented in Python. Versions from Python 2.5 onwards are supported, including Python 3.0 and successive.

PostgreSQL client-side development tools are required to build and install extensions.

Installation from the Python Package Index

The PGXN client is hosted on PyPI, therefore the easiest way to install the program is through a Python installation tool such as easy_install, pip or zc.buildout. For example a system-wide installation can be obtained with:

$ sudo easy_install pgxnclient

To upgrade from a previous version to the most recent available you may run instead:

$ sudo easy_install -U pgxnclient

The documentation of the installation tool of your choice will also show how to perform a local installation.

Installation from source

The program can also be installed from the source, either from a source package or from the source repository: in this case you can install the program using:

$ python setup.py install

Running from the project directory

You can also run PGXN Client directly from the project directory, either unpacked from a source package, or cloned from the source repository, without performing any installation.

Just make sure that the project directory is in the :envvar:`PYTHONPATH` and run the :program:`bin/pgxn` script:

$ cd /path/to/pgxnclient
$ export PYTHONPATH=`pwd`
$ ./bin/pgxn --version
pgxnclient 1.0.3.dev0   # just an example
Jump to Line
Something went wrong with that request. Please try again.