Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Commits on Jul 11, 2012
  1. Copyright bumped to 2012

    authored
Commits on Jul 10, 2012
  1. Dropped support for Python 2.4

    authored
    This way we don't have to worry about missing ordered dicts, can use
    try-except-finally, with construct etc.
    
    Actually I would drop py 2.5 as well, in order to use b"" strings, but for the
    moment I can live with the b() function.
Commits on Nov 28, 2011
  1. Fixed simplejson dependency on Python 2.6

    authored
    Fixes issue #8
Commits on Nov 27, 2011
  1. Releasing 1.0

    authored
Commits on Jun 24, 2011
  1. Package modified to make the command scripts work with setup.py

    authored
    The procedire is not entirely optimal: upon install the symlinks are
    replaced by scripts without the executable script. Commands dispatch
    works anyway though, and distro packagers are free to make a better work.
Commits on May 9, 2011
  1. Using tests_require instead of the Makefile to build the test env

    authored
    env directory dropped entirely, as all the dependencies are handled
    by setuptools now, selected according to the Python version.
    
    I like the Makefile now...
  2. The test suite can be run with Python 3

    authored
    Test suite moved as pgxnclient subpackage or 2to3 will not work with it.
Commits on May 8, 2011
  1. The program is compatible with Python 3

    authored
    Note that it still takes some refactoring before being able to run the unit
    test with Python 3.
  2. Switched to distutils to package the script

    authored
    This allows handling of dependencies for Python < 2.6, but it's been a mess.
Commits on May 1, 2011
  1. Package renamed from pgxn.client to pgxnclient

    authored
    After the comment from Marti (Raudesepp, I bet) that the point would lead
    to renames by the distributions.
Commits on Apr 28, 2011
  1. Bump to version 0.1a3

    authored
Commits on Apr 27, 2011
  1. Added setup script

    authored
    Version bumped to 0.1a1
Something went wrong with that request. Please try again.