Permalink
Browse files

Add bundler dependency for building/testing

  • Loading branch information...
1 parent 509cc4a commit 3da6bf16ac2d8ab64a6c54e5e20d7a7731e0a8df @dwaite committed Jun 13, 2010
Showing with 18 additions and 5 deletions.
  1. +1 −0 .gitignore
  2. +10 −0 Gemfile
  3. +3 −1 Rakefile
  4. +4 −4 cookiejar.gemspec
View
@@ -2,3 +2,4 @@
*.*proj
pkg
doc
+.bundle
View
10 Gemfile
@@ -0,0 +1,10 @@
+source "http://rubygems.org"
+
+group :build do
+ gem "yard"
+end
+
+group :test do
+ gem "json"
+ gem "rspec"
+end
View
@@ -1,4 +1,6 @@
require 'rubygems'
+require 'bundler'
+Bundler.setup(:default,:build,:test)
require 'rake'
require 'rake/clean'
@@ -32,7 +34,7 @@ task :test => :spec
spec = Gem::Specification.new do |s|
s.name = 'cookiejar'
- s.version = '0.2.9'
+ s.version = '0.2.9.pre'
s.summary = "Client-side HTTP Cookie library"
s.description =
%{Allows for parsing and returning cookies in Ruby HTTP client code}
View
@@ -2,25 +2,25 @@
Gem::Specification.new do |s|
s.name = %q{cookiejar}
- s.version = "0.2.9"
+ s.version = "0.3.0.pre"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["David Waite"]
- s.date = %q{2009-09-27}
+ s.date = %q{2010-06-12}
s.description = %q{Allows for parsing and returning cookies in Ruby HTTP client code}
s.email = %q{david@alkaline-solutions.com}
s.files = ["lib/cookiejar/cookie.rb", "lib/cookiejar/cookie_validation.rb", "lib/cookiejar/jar.rb", "lib/cookiejar.rb", "test/cookie_test.rb", "test/cookie_validation_test.rb", "test/jar_test.rb"]
s.homepage = %q{http://alkaline-solutions.com}
s.rdoc_options = ["--title", "CookieJar -- Client-side HTTP Cookies"]
s.require_paths = ["lib"]
- s.rubygems_version = %q{1.3.5}
+ s.rubygems_version = %q{1.3.7}
s.summary = %q{Client-side HTTP Cookie library}
if s.respond_to? :specification_version then
current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
s.specification_version = 3
- if Gem::Version.new(Gem::RubyGemsVersion) >= Gem::Version.new('1.2.0') then
+ if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
else
end
else

0 comments on commit 3da6bf1

Please sign in to comment.