Skip to content
This repository
Newer
Older
100644 32 lines (28 sloc) 1.107 kb
9f932ab3 »
2012-07-31 Added missing LICENSE.txt/README.txt and the setup.py
1 #!/usr/bin/env python
2 import os
5241eeaf »
2012-08-04 Added some missing files and updated the README.txt
3 from distutils.core import setup
9f932ab3 »
2012-07-31 Added missing LICENSE.txt/README.txt and the setup.py
4 """
f494bfcd »
2012-08-01 Fixes for install issues on Ubuntu 12.04
5 Copyright (c) 2012 Yahoo! Inc. All rights reserved.
9f932ab3 »
2012-07-31 Added missing LICENSE.txt/README.txt and the setup.py
6 Licensed under the Apache License, Version 2.0 (the "License");
7 you may not use this file except in compliance with the License.
8 You may obtain a copy of the License at
9
10 http://www.apache.org/licenses/LICENSE-2.0
11
12 Unless required by applicable law or agreed to in writing, software
13 distributed under the License is distributed on an "AS IS" BASIS,
14 WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
15 See the License for the specific language governing permissions and
16 limitations under the License. See accompanying LICENSE file.
17 """
18
19 setup(
20 name="sshmap",
5241eeaf »
2012-08-04 Added some missing files and updated the README.txt
21 version="0.2.28",
9f932ab3 »
2012-07-31 Added missing LICENSE.txt/README.txt and the setup.py
22 author="Dwight Hubbard",
23 author_email="dhubbard@yahoo-inc.com",
24 url="http://www.yahoo.com",
25 license="LICENSE.txt",
5241eeaf »
2012-08-04 Added some missing files and updated the README.txt
26 packages=["sshmap","hostlists","hostlists_plugins"],
f494bfcd »
2012-08-01 Fixes for install issues on Ubuntu 12.04
27 scripts=["sshmap/sshmap.py"],
9f932ab3 »
2012-07-31 Added missing LICENSE.txt/README.txt and the setup.py
28 long_description=open('README.txt').read(),
5241eeaf »
2012-08-04 Added some missing files and updated the README.txt
29 description="A SSH Multiplexer designed to use ssh to perform map/reduce like operations",
9f932ab3 »
2012-07-31 Added missing LICENSE.txt/README.txt and the setup.py
30 requires=['paramiko'],
31 )
Something went wrong with that request. Please try again.