Dylan bindings for LevelDB
Dylan Makefile
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
documentation
ext
registry/generic
tests
.gitignore
.gitmodules
LICENSE
Makefile
README.rst
TODO.rst
leveldb.dylan
leveldb.intr
leveldb.lid
library.dylan

README.rst

This library wraps leveldb.

Be sure to clone this recursively:

git clone --recursive <url for repo>

To do a build, use make so that the appropriate steps are executed.

Please note:

  • You must be using Open Dylan 2013.2 or later.
  • You will also need a build of melange from the melange repo in your $PATH if you need to re-generate leveldb.dylan.
  • leveldb.dylan is auto-generated by melange and should not be edited.
  • You must have Google's Snappy library installed.

See the TODO.rst for a more complete list of issues to be addressed.