Permalink
Browse files

Fixed <script> loading.

  • Loading branch information...
kriskowal committed Jun 9, 2011
1 parent 47fc057 commit a6e9060fe933dce1dae2708c8a3163dfb0a2f3b2
Showing with 14 additions and 18 deletions.
  1. +4 −0 CHANGES
  2. +7 −1 package.json
  3. +0 −7 q-0.2.4.min.js
  4. +0 −8 q-0.4.0.min.js
  5. +2 −2 q.js
  6. +1 −0 q.min.js
View
@@ -1,5 +1,9 @@
# vim:ts=4:sts=4:sw=4:et:tw=60
+0.4.3
+ - Fixed <script> support that regressed with 0.4.2 because
+ of "use strict" in the module system multi-plexer.
+
0.4.2
- Added support for RequireJS (jburke)
View
@@ -1,7 +1,7 @@
{
"name": "q",
"description": "A library for promises (CommonJS/Promises/A,B,D)",
- "version": "0.4.2",
+ "version": "0.4.3",
"homepage": "http://github.com/kriskowal/q/",
"author": "Kris Kowal <kris@cixar.com> (http://github.com/kriskowal/)",
"contributors": [
@@ -31,6 +31,12 @@
"test": ">=0.0.7",
"event-queue": ">=0.0.1"
},
+ "devDependencies": {
+ "uglify-js": ">= 0.0.5"
+ },
+ "scripts": {
+ "prepublish": "uglifyjs -o q.min.js -nc q.js"
+ },
"overlay": {
"teleport": {
"dependencies": {
View

Some generated files are not rendered by default. Learn more.

Oops, something went wrong.
View

Some generated files are not rendered by default. Learn more.

Oops, something went wrong.
View
4 q.js
@@ -11,7 +11,7 @@
*/
(function (definition, undefined) {
- "use strict";
+
// This file will function properly as a <script> tag, or a module
// using CommonJS and NodeJS or RequireJS module formats. In
// Common/Node/RequireJS, the module exports the Q API and when
@@ -23,7 +23,7 @@
// replaced with a single-character.
// RequireJS
- if (typeof define === "function" && define.amd) {
+ if (typeof define === "function") {
define(function (require, exports) {
definition(require, exports);
});
View

Some generated files are not rendered by default. Learn more.

Oops, something went wrong.

0 comments on commit a6e9060

Please sign in to comment.