Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse code

releasing gem v0.1.0

  • Loading branch information...
commit 28eaf1bc99000a457b36996882696a085c13aa57 1 parent b1d3d66
Ryan Bates authored November 16, 2009
1  .gitignore
... ...
@@ -0,0 +1 @@
  1
+*.gem
3  CHANGELOG.rdoc
Source Rendered
... ...
@@ -0,0 +1,3 @@
  1
+*0.1.0* (Nov 16th, 2009)
  2
+
  3
+* initial release
12  README.rdoc
Source Rendered
@@ -7,11 +7,17 @@ This assumes you already have an authentication solution (such as Authlogic) whi
7 7
 
8 8
 == Installation
9 9
 
10  
-Install it as a Rails plugin.
  10
+You can set it up as a gem in your environment.rb file.
  11
+  
  12
+  config.gem "cancan", :source => "http://gemcutter.org"
  13
+  
  14
+And then install the gem.
11 15
 
12  
-  script/plugin install git://github.com/ryanb/cancan.git
  16
+  gem install cancan
13 17
 
14  
-It will be available as a gem soon.
  18
+Alternatively you can install it as a Rails plugin.
  19
+
  20
+  script/plugin install git://github.com/ryanb/cancan.git
15 21
 
16 22
 
17 23
 == Setup
22  cancan.gemspec
... ...
@@ -0,0 +1,22 @@
  1
+Gem::Specification.new do |s|
  2
+  s.name = "cancan"
  3
+  s.summary = "Simple authorization solution for Rails."
  4
+  s.description = "Simple authorization solution for Rails which is completely decoupled from the user's roles. All permissions are stored in a single location for convenience."
  5
+  s.homepage = "http://github.com/ryanb/cancan"
  6
+  
  7
+  s.version = "0.1.0"
  8
+  s.date = "2009-11-16"
  9
+  
  10
+  s.authors = ["Ryan Bates"]
  11
+  s.email = "ryan@railscasts.com"
  12
+  
  13
+  s.require_paths = ["lib"]
  14
+  s.files = Dir["lib/**/*"] + Dir["spec/**/*"] + ["LICENSE", "README.rdoc", "Rakefile", "CHANGELOG.rdoc", "init.rb"]
  15
+  s.extra_rdoc_files = ["README.rdoc", "CHANGELOG.rdoc", "LICENSE"]
  16
+  
  17
+  s.has_rdoc = true
  18
+  s.rdoc_options = ["--line-numbers", "--inline-source", "--title", "CanCan", "--main", "README.rdoc"]
  19
+  
  20
+  s.rubygems_version = "1.3.4"
  21
+  s.required_rubygems_version = Gem::Requirement.new(">= 1.2")
  22
+end

0 notes on commit 28eaf1b

Please sign in to comment.
Something went wrong with that request. Please try again.