Skip to content

dynatrace-extensions/dt-extensions-python-sdk

Folders and files

NameName
Last commit message
Last commit date

Latest commit

 

History

79 Commits
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Repository files navigation

Dynatrace Extensions Python SDK

PyPI - Version PyPI - Python Version


Table of Contents

Documentation

The documentation can be found on github pages

Quick Start

Requirements:

  • Python 3.10+

Install the SDK

pip install dt-extensions-sdk[cli]
# Note, on some shells like zsh you may need to escape the brackets - pip install dt-extensions-sdk\[cli\]

Create signing certificates

dt-sdk gencerts

Create a new extension

dt-sdk create my_first_extension

Simulate

cd my_first_extension
dt-sdk run

Build

dt-sdk build

Upload

# Note, you need to either set environment variables DT_API_URL and DT_API_TOKEN or pass them as arguments
dt-sdk upload

Developing

Testing

hatch run test

Linting

hatch run lint:all

Building

hatch build

Building docs

hatch run docs:build

License

dt-extensions-sdk is distributed under the terms of the MIT license.

Publishing to PyPI

It's automatically published to PyPi on each pushed tag, and uses gh-action-pypi-publish Version will be determined using about.py