Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
The original jQuery autocompleter. Does not need any other plugins. Supports local and remote data sets, plain text and JSON data, various options and callback hooks.
branch: master

README.md

jquery-autocomplete

NOTE: THIS PROJECT IS RETIRED / ABANDONED

The time has come to retire this project. The code is not up to my current programming standards, and I don't feel motivated enought to go through another rewrite. There is also not much need, because of excellent alternatives like Select2 (http://ivaynberg.github.io/select2/) and the various jQuery autocomplete efforts that have evolved from or parrallel to my original (just google jquery autocomplete).

This means that current and future bugs probably won't be fixed, unless the project finds a new caretaker. Contact me if you are interested in that role.

I'm immensely proud of the fact that this autocompleter has served as long as it has. It's found is way into all kinds of web sites (up to and inclusing Barack Obama's election compaign) applications and projects. Thank you all!

Dylan Verheul http://dyve.net

What is it?

Transforms an INPUT element into an autocompleter. The autocompleter helps the user pick a value value from a list by showing available values based on keyboard input.

Supports local (JavaScript object) and remote data sets. Remote data sets can be delivered as plain text or JSON.

Works out of the box, but highly configurable using options and callback hooks.

Usage

To get started, copy the files from the src/ folder to your project, and link your HTML to it. Like this:

<link rel="stylesheet" type="text/css" href="PATH_TO_SRC/jquery.autocomplete.css">
<script src="PATH_TO_JQUERY/jquery.min.js" type="text/javascript"></script>
<script src="PATH_TO_SRC/jquery.autocomplete.js" type="text/javascript"></script>

<script type="text/javascript">
    $("#input").autocomplete("/path/to/backend.php");
</script>

For more info refer to the docs (doc/jquery.autocomplete.txt).

Dependencies

The only requirement for jquery-autocomplete is jQuery. No other plugins are required.

Bug tracker

Have a bug? Please create an issue here on GitHub!

https://github.com/dyve/jquery-autocomplete/issues

Twitter account

Keep up to date on announcements and more by following jquery-autocomplete on Twitter, @jqautocomplete.

Author

Dylan Verheul

Contributors

Allart Kooiman François Schiettecatte

Copyright and license

See LICENSE.txt file.

Something went wrong with that request. Please try again.