New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[OSQA-932] Bitnami OSQA error: 'Settings' object has no attribute 'MODULE_LIST' #494

Open
javierder opened this Issue May 13, 2015 · 0 comments

Comments

Projects
None yet
1 participant
@javierder
Member

javierder commented May 13, 2015

[reporter="mikhailm", created="Fri, 5 Jul 2013 02:32:25 -0400"]
I have installed virtual machine with Bitnami OSQA stack. It works fine. But when I run debugging in PyCharm and connect to 127.0.0.1:8000 in browser, I get




    Connected to pydev debugger (build 129.782)


    /opt/bitnami/python/lib/python2.7/site-packages/MySQL_python-1.2.3c1-py2.7-linux-x86_64.egg/_mysql.py:3: UserWarning: Module django was already imported from /opt/bitnami/apps/django/lib/python2.7/site-packages/django/init.pyc, but /opt/bitnami/python/lib/python2.7/site-packages is being added to sys.path


    Validating models...


    


    0 errors found


    Django version 1.3.6, using settings 'settings'


    Development server is running at http://localhost:8000/


    Quit the server with CONTROL-C.


    Traceback (most recent call last):


      File "/opt/bitnami/apps/django/lib/python2.7/site-packages/django/core/servers/basehttp.py", line 283, in run


        self.result = application(self.environ, self.start_response)


      File "/opt/bitnami/apps/django/lib/python2.7/site-packages/django/contrib/staticfiles/handlers.py", line 68, in call


        return self.application(environ, start_response)


      File "/opt/bitnami/apps/django/lib/python2.7/site-packages/django/core/handlers/wsgi.py", line 250, in call


        self.load_middleware()


      File "/opt/bitnami/apps/django/lib/python2.7/site-packages/django/core/handlers/base.py", line 45, in load_middleware


        mod = import_module(mw_module)


      File "/opt/bitnami/apps/django/lib/python2.7/site-packages/django/utils/importlib.py", line 35, in import_module


        import(name)


      File "/opt/bitnami/apps/osqa/forum/middleware/extended_user.py", line 3, in


        from forum.models.user import AnonymousUser


      File "/opt/bitnami/apps/osqa/forum/models/init.py", line 1, in


        import forum.utils.djangofix


      File "/opt/bitnami/apps/osqa/forum/utils/djangofix.py", line 21, in


        from forum import settings


      File "/opt/bitnami/apps/osqa/forum/settings/init.py", line 56, in


        for k,v in get_modules_script_implementations('settings', BaseSetting).items():


      File "/opt/bitnami/apps/osqa/forum/modules/init.py", line 37, in get_modules_script_implementations


        scripts = get_modules_script(script_name)


      File "/opt/bitnami/apps/osqa/forum/modules/init.py", line 17, in get_modules_script


        for m in settings.MODULE_LIST:


      File "/opt/bitnami/apps/django/lib/python2.7/site-packages/django/utils/functional.py", line 277, in getattr


        return getattr(self._wrapped, name)


    AttributeError: 'Settings' object has no attribute 'MODULE_LIST'


    [04/Jul/2013 05:23:56] "GET / HTTP/1.1" 500 1851

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment