Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Only add -wdouble-promotion if supported #65

Merged
merged 3 commits into from
Jul 5, 2021
Merged

Conversation

gavanderhoorn
Copy link
Contributor

@gavanderhoorn gavanderhoorn commented Jul 3, 2021

As per subject.

GCC 4.6.0 is already really old, but the compiler I'm targetting is even older.

The unconditional addition of -wdouble-promotion causes builds to fail so I patch this out locally.

It would be great if this could be merged here, so I have one less patch to apply.


Edit: link to the GCC 4.6.0 docs: Options to Request or Suppress Warnings, and the same page, but for GCC 4.5.4. The former has the option, the latter doesn't.

@richiprosima
Copy link
Contributor

Build status:

  • Linux Build Status
  • Windows Build Status

@richiprosima
Copy link
Contributor

Build status:

  • Linux Build Status
  • Windows Build Status

@pablogs9 pablogs9 changed the base branch from master to develop July 5, 2021 10:48
cmake/common/check_configuration.cmake Outdated Show resolved Hide resolved
Signed-off-by: gavanderhoorn <g.a.vanderhoorn@tudelft.nl>
@richiprosima
Copy link
Contributor

Build status:

  • Linux Build Status
  • Windows Build Status

@pablogs9
Copy link
Member

pablogs9 commented Jul 5, 2021

Thanks!

@pablogs9 pablogs9 merged commit 21c99e0 into eProsima:develop Jul 5, 2021
@gavanderhoorn gavanderhoorn deleted the patch-1 branch July 5, 2021 12:14
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

Successfully merging this pull request may close these issues.

None yet

4 participants