Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Error when opening model designer #449

Closed
jacobdeboer33 opened this issue Jun 18, 2019 · 3 comments

Comments

Projects
None yet
2 participants
@jacobdeboer33
Copy link

commented Jun 18, 2019

Hi Tolis

I am trying to open my model designer in Visual Studio of a Win project of our product. I'm getting the following error in the designer.

Exception occurs while initializing the 'Xpand.XAF.Modules.CloneMemberValue.CloneMemberValueModule' module: Method not found: 'System.IObservable1<System.Reactive.Unit> Xpand.XAF.Modules.Reactive.Extensions.CommonExtensions.ToUnit(System.IObservable1<!!0>)'.
at DevExpress.ExpressApp.ApplicationModulesManager.SetupModules()
at DevExpress.ExpressApp.ApplicationModulesManager.Load(ITypesInfo typesInfo, Boolean loadTypesInfo)
at DevExpress.ExpressApp.Utils.DesignerModelFactory.CreateModulesManager(ModuleBase module, String assembliesPath, List1 additionalModules, ISecurityStrategyBase securityInstance) at DevExpress.ExpressApp.Design.ModelEditor.ModelLoader.LoadModel(ITypeDiscoveryService typeDiscoveryService, ITypeResolutionService typeResolutionService, String targetDiffFileName, IDisposable& obj) at DevExpress.ExpressApp.Design.ModelEditor.EditorPane.CreateModelEditorController() at DevExpress.ExpressApp.Design.ModelEditor.EditorPane.PrivateInit(String fileName, ProjectItem currentProjectItem, IVsHierarchy pvHier) ----------InnerException---------- Method not found: 'System.IObservable1<System.Reactive.Unit> Xpand.XAF.Modules.Reactive.Extensions.CommonExtensions.ToUnit(System.IObservable`1<!!0>)'.
----------StackTrace----------
at Xpand.XAF.Modules.CloneMemberValue.CloneMemberValueService.Connect(ApplicationModulesManager modulesManager, XafApplication application)
at Xpand.XAF.Modules.CloneMemberValue.CloneMemberValueModule.Setup(ApplicationModulesManager moduleManager) in D:\a\1\s\src\Modules\CloneMemberValue\Module.cs:line 15
at DevExpress.ExpressApp.ApplicationModulesManager.SetupModules()

I'm using the 1.2.32 version of the clonemembervalue and the 1.2.32 version of the reactive module.

Is there something I can do to solve this?

Thanks,
Jacob

@apobekiaris

This comment has been minimized.

Copy link
Member

commented Jun 18, 2019

Method not found: 'System.IObservable1<System.Reactive.Unit> Xpand.XAF.Modules.Reactive.Extensions.CommonExtensions.ToUnit(System.IObservable1<!!0>)'.

what about System.Reactive package? is this referenced? it should be as a dependency

@apobekiaris apobekiaris removed their assignment Jun 26, 2019

@jacobdeboer33

This comment has been minimized.

Copy link
Author

commented Jul 19, 2019

It seems that this package is referenced. I will now close this ticket until I have time to look at this further

Thanks,
Jacob

@apobekiaris

This comment has been minimized.

Copy link
Member

commented Jul 19, 2019

in addition I suggest you try the XpandModelEditor instead.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.