New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Secondary, blank repository appears repeatedly in Repositories view #405

Closed
mliq opened this Issue Jun 7, 2018 · 5 comments

Comments

Projects
None yet
2 participants
@mliq

mliq commented Jun 7, 2018

  • GitLens Version: 8.3.3
  • VSCode Version: 1.24.0 (also occurred on 1.23.1)
  • OS Version: 10.13.5

Steps to Reproduce:

  1. Work as normal in a large single repository project. (Note that this project does have a second package.json and .gitignore in a subfolder, but it does not have a git repo there.)
  2. Eventually, notice that gitExplorer shows a secondary, completely blank repository.
  3. Close the blank repository via right click menu.
  4. Minutes or hours later, the empty repository reappears.
    repeat ad infinitum.

Note that the VSCode build in VCS does not appear to have this issue.

Things I have tried unsuccessfully:
"git.autoRepositoryDetection": false
"gitlens.advanced.repositorySearchDepth": 0

screenshot 2018-06-07 16 32 12 copy

@eamodio

This comment has been minimized.

Owner

eamodio commented Jun 8, 2018

@mliq And there is no .git folder some where else in the folder tree? If not, are you opening any files outside of the workspace, because GitLens will try to detect repos for just single files opened in the same window.

Can you please enable output channel logging by setting "gitlens.outputLevel": "verbose" in your settings.json. This will enable logging to the GitLens channel in the Output pane. Once enabled, please attempt to reproduce the issue (if possible) and attach the relevant log lines from the GitLens channel.

@mliq

This comment has been minimized.

mliq commented Jun 8, 2018

@eamodio

  • there are no other .git folders. However, one subdirectory does contain a secondary .gitignore and .vscode - could this impact it?
  • I am not opening any files outside of the workspace when this happens.
  • turned on logging and will submit here when it happens again.
@eamodio

This comment has been minimized.

Owner

eamodio commented Jun 8, 2018

Thanks, none of those things should affect GitLens finding a repo. Looking forward to the logs.

@eamodio

This comment has been minimized.

Owner

eamodio commented Jul 9, 2018

I am closing this issue because it needs more information and has not had recent activity. Please re-open this issue when more details can be provided.

Thanks!

@eamodio eamodio closed this Jul 9, 2018

@mliq

This comment has been minimized.

mliq commented Aug 23, 2018

@eamodio I am not able to re-open, should I make a duplicate or can you re-open?
I have continued to have this problem multiple times per day.

Attached here is a log:
gitlens_moreprecise.log

  • At line 1484 I had just deleted the empty repository
  • By line 1524 the empty repository was back!

@eamodio eamodio reopened this Aug 23, 2018

@eamodio eamodio added bug and removed needs more info labels Sep 5, 2018

@eamodio eamodio self-assigned this Sep 5, 2018

@eamodio eamodio added this to the Soonish™ milestone Sep 5, 2018

eamodio added a commit that referenced this issue Sep 7, 2018

Reworks git commands a bit to reduce rethrows
Fixes #405 - stops non-repo from showing up in explorer

@eamodio eamodio modified the milestones: Soonish™, Soon™ Sep 30, 2018

@eamodio eamodio changed the title from Secondary, blank repository appears repeatedly in gitExplorer view to Secondary, blank repository appears repeatedly in Repositories view Nov 25, 2018

@eamodio eamodio closed this in d7212eb Dec 2, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment