New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Apply Changes not working because of whitespace conflicts #574

Closed
tiansin opened this Issue Dec 5, 2018 · 5 comments

Comments

Projects
None yet
2 participants
@tiansin
Copy link

tiansin commented Dec 5, 2018

  • GitLens Version: 9.02
  • VSCode Version: 1.2.9
  • OS Version: mac 10.13.6

Steps to Reproduce:

This feature is not available for both the repository and submodules

@eamodio

This comment has been minimized.

Copy link
Owner

eamodio commented Dec 5, 2018

Can you provide more details and steps for what you are seeing?

@tiansin

This comment has been minimized.

Copy link

tiansin commented Dec 12, 2018

qq20181212-170031 2x

@eamodio Always prompt this, choose Yes.

@eamodio

This comment has been minimized.

Copy link
Owner

eamodio commented Dec 12, 2018

So when you say Yes it doesn't apply the changes to the working tree?

@tiansin

This comment has been minimized.

Copy link

tiansin commented Dec 12, 2018

qq20181212-171411 2x

`
[2018-12-12 09:13:18:971] git — -c, core.quotepath=false, -c, color.ui=false, apply, cwd='/Users/xxxx/xxxx/xxxx/xxx/src/app/Services'

Error: :33: trailing whitespace.
* @param url
error: patch failed: Public/plat.class.ts:5
error: Public/plat.class.ts: patch does not apply

[2018-12-12 09:13:20:734] git — -c, core.quotepath=false, -c, color.ui=false, apply, -3, cwd='/Users/xxxx/xxxx/xxxx/xxx/src/app/Services'

Error: :33: trailing whitespace.
* @param url
error: patch failed: Public/plat.class.ts:5
Falling back to three-way merge...
error: patch failed: Public/plat.class.ts:5
error: Public/plat.class.ts: patch does not apply

[2018-12-12 09:13:20:734] Object
Error: :33: trailing whitespace.
* @param url
error: patch failed: Public/plat.class.ts:5
Falling back to three-way merge...
error: patch failed: Public/plat.class.ts:5
error: Public/plat.class.ts: patch does not apply
`

@eamodio

@eamodio

This comment has been minimized.

Copy link
Owner

eamodio commented Dec 12, 2018

On the command line what happens if you run:
git apply --whitespace=warn -3

@eamodio eamodio added bug and removed needs more info labels Dec 13, 2018

@eamodio eamodio added this to the Soon™ milestone Dec 13, 2018

@eamodio eamodio changed the title scm Apply Changes Not working Apply Changes not working because of whitespace conflicts Dec 13, 2018

@eamodio eamodio self-assigned this Dec 13, 2018

@eamodio eamodio closed this in 0799fab Dec 13, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment