New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Wrong URL to open commit on Azure DevOps if cloned via SSH #620

Closed
Eskibear opened this Issue Jan 10, 2019 · 0 comments

Comments

Projects
None yet
2 participants
@Eskibear
Copy link
Contributor

Eskibear commented Jan 10, 2019

  • GitLens Version: 9.4.1
  • VSCode Version: 1.30.1
  • OS Version: Win10 Ent

Steps to Reproduce:

  1. Clone and open a repo from Azure DevOps.
  2. Choose a commit to "open commit on Azure DevOps"
  3. Page is 404

I can give you some edge cases:

Example 1 (visualstudio.com)

Cloning URL via HTTPS:

https://<org>.visualstudio.com/DefaultCollection/<project>/_git/<repo>
https://<org>.visualstudio.com/<project>/_git/<repo>

Cloning URL via SSH:

<org>@vs-ssh.visualstudio.com:v3/<org>/<project>/<repo>

⚠️
In this case, domain is parsed to "vs-ssh.visualstudio.com", but should be <org>.visualstudio.com
And path misses "_git" part.

Correct commit URL:

https://<org>.visualstudio.com/DefaultCollection/<project>/_git/<repo>/commit/<commit-id>
https://<org>.visualstudio.com/<project>/_git/<repo>/commit/<commit-id>

Example 2 (dev.azure.com)

Cloning URL via HTTPS:

https://<org>@dev.azure.com/<org>/<project>/_git/<repo>

Cloning URL via SSH:

git@ssh.dev.azure.com:v3/<org>/<project>/<repo>

⚠️
In this case, domain is correctly parsed to dev.azure.com, but path misses "_git" part.

Correct commit URL:

https://dev.azure.com/<org>/<project>/_git/<repo>/commit/<commit-id>

@eamodio eamodio added the type: bug label Jan 23, 2019

@eamodio eamodio added this to the Soon™ milestone Jan 23, 2019

@eamodio eamodio closed this Feb 6, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment