New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update maven-javadoc-plugin to 2.7 (Maven build broken) #54

Closed
henri-tremblay opened this Issue Jun 3, 2015 · 1 comment

Comments

Projects
None yet
1 participant
@henri-tremblay
Contributor

henri-tremblay commented Jun 3, 2015

Migrated from: CodeHaus issue EASYMOCK-43
Original reporter: Henri Tremblay


The existing version (2.6.1) of maven-javadoc-plugin used in the build can cause a top-level build to fail on Maven 2.2.1:

[INFO] Unable to find resource 'org.easymock:easymock:jar:3.1-SNAPSHOT' in repository snapshots (http://snapshots)
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Failed to resolve artifact.

Missing:
----------
1) org.easymock:easymock:jar:3.1-SNAPSHOT

I believe that this is a known problem with this plugin, which can be fixed by moving up to version 2.7.

POM patch attached.

@henri-tremblay

This comment has been minimized.

Show comment
Hide comment
@henri-tremblay

henri-tremblay Jun 3, 2015

Contributor

Original comment author: Henri Tremblay


All plugins updated to latest version

Contributor

henri-tremblay commented Jun 3, 2015

Original comment author: Henri Tremblay


All plugins updated to latest version

@henri-tremblay henri-tremblay self-assigned this Jun 3, 2015

@henri-tremblay henri-tremblay added this to the 3.1 milestone Jun 3, 2015

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment