Skip to content
Browse files

Update API and Fix Docs.

git-svn-id: svn://rubyforge.org/var/svn/rqr/trunk@5 301401ff-d6d1-48cb-99de-69ad7ad2dacb
  • Loading branch information...
1 parent 74f479c commit d95bac1199d4a2d61f6cc4d6d9a1fdb27456f862 pools committed May 25, 2008
Showing with 11 additions and 7 deletions.
  1. +5 −1 History.txt
  2. +1 −1 License.txt
  3. +2 −2 README.txt
  4. +3 −3 lib/rqr/qrcode.rb
View
6 History.txt
@@ -1,4 +1,8 @@
+== 0.1.1 2008-05-26
+
+* Update API.
+
== 0.1.0 2008-05-23
* 1 major enhancement:
- * Initial release
+ * Initial release
View
2 License.txt
@@ -1,6 +1,6 @@
Note: Original QR_Encode.h and QR_Encode.cpp are free license. (by Psytec Inc)
-Copyright (c) 2008 Ryota Maruko, Keiko Soejima
+Copyright (c) 2008 Ryota Maruko, Keiko Soezima
Permission is hereby granted, free of charge, to any person obtaining
a copy of this software and associated documentation files (the
View
4 README.txt
@@ -4,7 +4,7 @@
== DESCRIPTION:
-A ruby library to create qrcode. Output: PS, JPEG, PNG, EPS, TIFF.
+A ruby library to create QR code image. Output: PS, JPEG, PNG, EPS, TIFF.
== SYNOPSIS:
@@ -55,7 +55,7 @@ If using OSX, Use Fink(http://www.finkproject.org) Universal Binary libs.
(The MIT License)
-Copyright (c) 2008 Ryota Maruko, Keiko Soejima
+Copyright (c) 2008 Ryota Maruko, Keiko Soezima
Permission is hereby granted, free of charge, to any person obtaining
a copy of this software and associated documentation files (the
View
6 lib/rqr/qrcode.rb
@@ -4,13 +4,13 @@ class QRCode
# options
# :level L:0, M:1(default), Q:2, H:3
# :version S:0(default), M:1, L:2
- # :autoextent true(default)|false auto extent if over version size
+ # :auto_extend true(default)|false auto extent if over version size
# :masking masking pattern 0-7, -1(default auto)
# :length data length
# :module_size module pixel size
# :eps_preview true|false(default)
def initialize(options = {})
- @options = { :level => 1, :version => 0, :autoextend => true,
+ @options = { :level => 1, :version => 0, :auto_extend => true,
:masking => -1, :eps_preview => false, :module_size => 4 }
@options.merge!(options)
end
@@ -55,7 +55,7 @@ def get_format(path)
def init_encoder(data)
@encoder = QR::CQR_Encode.new
- unless @encoder.EncodeData(@options[:level], @options[:version], @options[:autoextend], @options[:masking], data)
+ unless @encoder.EncodeData(@options[:level], @options[:version], @options[:auto_extend], @options[:masking], data)
close; raise EncodeException.new("qrcode encord error!")
end
end

0 comments on commit d95bac1

Please sign in to comment.
Something went wrong with that request. Please try again.