Permalink
Browse files

Tests use the hamcrest core API directly, it should be explicitly called

out in the manifest so we don't rely on other bundles re-exporting API.

Signed-off-by: Mat Booth <mat.booth@redhat.com>
  • Loading branch information...
1 parent e258828 commit 606f0f151931d076f9f564ef563e9275b4a025b5 @mbooth101 mbooth101 committed Jan 20, 2015
Showing with 2 additions and 0 deletions.
  1. +1 −0 CHANGES.md
  2. +1 −0 com.github.eclipsecolortheme.test/META-INF/MANIFEST.MF
View
@@ -1,5 +1,6 @@
1.1.0
=====
+* Explicitly import hamcrest core bundle for tests.
1.0.0 (2014-10-26)
==================
@@ -7,4 +7,5 @@ Bundle-Vendor: GitHub
Bundle-RequiredExecutionEnvironment: JavaSE-1.6
Require-Bundle: com.github.eclipsecolortheme;bundle-version="0.9.0",
org.junit,
+ org.hamcrest.core,
org.eclipse.core.runtime;bundle-version="3.6.0"

0 comments on commit 606f0f1

Please sign in to comment.