Skip to content
Java Other
  1. Java 99.6%
  2. Other 0.4%
Branch: master
Clone or download

README.adoc

Dartboard Jenkins Version

Dartboard is an Eclipse plugin for Dart and Flutter development. The Dartboard official Twitter account is @DartEclipse

60813009 0e148100 a193 11e9 95e8 63f08fcea976

Dart and the related logo are trademarks of Google LLC. We are not endorsed by or affiliated with Google LLC.

Prerequisites

This project requires a recent version of the Wild Web Developer. You have to install this first if your Eclipse installation does not already include it.

Installation

Download and install at least Dart 2.2. from the Dart download page.

Check by running $ dart --version after installation.

Install the Eclipse plugin from the Marketplace or use the btn install button.

There is also p2 update sites available at.

Nightly:

0.1 release:

Features

Thanks to the language server protocol and the analysis server provided by the Dart team Dartboard already contains many features.

The language server provides the necessary analysis and TextMate grammars provide syntax highlighting to enrich the development experience.

Syntax Highlight

  • Running Dart programs directly from the IDE

Dart Console

How to build

To build the project use Maven. Please note that 3.6.1 and 3.6.2 have a bug, use either a later version or Maven 3.6.0.

mvn clean verify

Contributing

There are many ways in which you can participate in the project, for example:

If you are interested in fixing issues or contributing directly to the code base, please see the document How to Contribute. and Development wiki for instructions on how to contribute to the repository.

CI is available at Eclipse Foundation Jenkins

You can’t perform that action at this time.