Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

DL4J: ComputationGraph.getParam can infer wrong layer name when name has underscores #6734

Closed
AlexDBlack opened this issue Nov 19, 2018 · 1 comment

Comments

@AlexDBlack
Copy link
Contributor

commented Nov 19, 2018

Example: getParam("block1_conv1_b") tries to get layer block1 instead of block1_conv1.
Should be easy fix.

AlexDBlack added a commit that referenced this issue Nov 27, 2018
AlexDBlack added a commit that referenced this issue Nov 27, 2018
Misc DL4J/ND4J fixes (#6774)
* #6770 Fix issue with incorrect EWS for TAD resulting in column vectors

* #6748 Add NaN checks in evaluation

* #6735 Add validation for invalid evaluation

* #6734 Fix ComputationGraph layer name inference from param name (get/setParam etc methods)

* #6736 additional CompGraph output overload

* Add commit() in ParallelInference

* Small fix

* put commit() in proper location

* Layer config cloning should clone INDArray fields to avoid excessive relocation issues on CUDA

* ParallelInference: Add commit before passing input array(s) between threads

* Trigger CI
@lock

This comment has been minimized.

Copy link

commented Dec 28, 2018

This thread has been automatically locked since there has not been any recent activity after it was closed. Please open a new issue for related bugs.

@lock lock bot locked and limited conversation to collaborators Dec 28, 2018

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
1 participant
You can’t perform that action at this time.