Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

bug 390578: lua target support now scp files service

  • Loading branch information...
commit ed68ebaa865af75e11600473e69f2f1f70da9ae7 1 parent ee31cfb
@sbernard31 sbernard31 authored
View
1  .gitignore
@@ -3,3 +3,4 @@ bin/
.DS_Store
target/
workspace/
+/plugin_customization.ini
View
3  features/org.eclipse.koneki.ldt.remote-feature/feature.xml
@@ -18,7 +18,8 @@
</license>
<requires>
- <import feature="org.eclipse.rse" version="3.4.0.201205300905-7L7IFBV83omxZWwIDyHWipb2Sz-f"/>
+ <import feature="org.eclipse.rse.scp" match="greaterOrEqual"/>
+ <import feature="org.eclipse.rse" match="greaterOrEqual"/>
</requires>
<plugin
View
2  plugins/org.eclipse.koneki.ldt.remote.core/plugin.xml
@@ -10,7 +10,7 @@
id="org.eclipse.koneki.ldt.remote.core.luasystemtype"
label="%lua.systemType.label"
name="luasystemtype"
- subsystemConfigurationIds="ssh.files;ssh.terminals;ssh.lua">
+ subsystemConfigurationIds="ssh.files;scp.files;ssh.terminals;ssh.lua">
</systemType>
</extension>
<extension
View
131 product/org.eclipse.koneki.ldt.remote.product
@@ -1,80 +1,79 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<?pde version="3.5"?>
-
-<product name="Lua Development Tools Product (Incubation)" uid="org.eclipse.koneki.ldt.remote-product" id="org.eclipse.koneki.ldt.branding.product" application="org.eclipse.ui.ide.workbench" version="0.9.0.qualifier" useFeatures="true" includeLaunchers="true">
-
- <aboutInfo>
- <image path="/org.eclipse.koneki.ldt.branding/ldt_about.png"/>
- <text>
+<?xml version="1.0" encoding="UTF-8"?>
+<?pde version="3.5"?>
+
+<product name="Lua Development Tools Product (Incubation)" uid="org.eclipse.koneki.ldt.remote-product" id="org.eclipse.koneki.ldt.branding.product" application="org.eclipse.ui.ide.workbench" version="0.9.0.qualifier" useFeatures="true" includeLaunchers="true">
+
+ <aboutInfo>
+ <image path="/org.eclipse.koneki.ldt.branding/ldt_about.png"/>
+ <text>
Lua Development Tools
© Copyright Eclipse contributors and others 2000, 2012. All rights reserved.
This product includes software developed by the Apache Software Foundation http://www.apache.org/
-Visit http://www.eclipse.org/koneki/ldt for more information.
- </text>
- </aboutInfo>
-
- <configIni use="default">
- </configIni>
-
- <launcherArgs>
+Visit http://www.eclipse.org/koneki/ldt for more information.
+ </text>
+ </aboutInfo>
+
+ <configIni use="default">
+ </configIni>
+
+ <launcherArgs>
<programArgs>-name
&quot;Lua Development Tools&quot;
--launcher.XXMaxPermSize
256m
--launcher.defaultAction
-openFile</programArgs>
+openFile</programArgs>
<programArgsLin>-startup
-plugins/org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar</programArgsLin>
+plugins/org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar</programArgsLin>
<programArgsMac>-startup
-../../../plugins/org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar</programArgsMac>
+../../../plugins/org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar</programArgsMac>
<programArgsWin>-startup
-plugins\org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar</programArgsWin>
- <vmArgs>-XX:PermSize=512M -XX:MaxPermSize=512M -Xms40m -Xmx512m</vmArgs>
- <vmArgsMac>-XstartOnFirstThread -Dorg.eclipse.swt.internal.carbon.smallFonts</vmArgsMac>
- </launcherArgs>
-
- <windowImages i16="/org.eclipse.koneki.ldt.branding/icons/LDT_16.png" i32="/org.eclipse.koneki.ldt.branding/icons/LDT_32.png" i64="/org.eclipse.koneki.ldt.branding/icons/LDT_64.png" i128="/org.eclipse.koneki.ldt.branding/icons/LDT_128.png"/>
-
- <splash
- location="org.eclipse.koneki.ldt.branding"
- startupProgressRect="3,281,493,14"
- startupMessageRect="7,260,350,20"
- startupForegroundColor="D4BAA9" />
- <launcher name="LuaDevelopmentTools">
- <linux icon="../../../../plugins/org.eclipse.koneki.ldt.branding/icons/ldt.xpm"/>
- <macosx icon="../../../../plugins/org.eclipse.koneki.ldt.branding/icons/ldt.icns"/>
- <solaris/>
- <win useIco="true">
- <ico path="../../../../plugins/org.eclipse.koneki.ldt.branding/icons/ldt.ico"/>
- <bmp/>
- </win>
- </launcher>
-
-
- <vm>
- </vm>
-
-
- <plugins>
- </plugins>
-
- <features>
- <feature id="org.eclipse.koneki.ldt.product" version="0.9.0.qualifier"/>
- <feature id="org.eclipse.koneki.ldt.remote" version="0.9.0.qualifier"/>
- <feature id="org.eclipse.rse"/>
- </features>
-
- <configurations>
- <plugin id="org.eclipse.core.runtime" autoStart="true" startLevel="4" />
- <plugin id="org.eclipse.equinox.common" autoStart="true" startLevel="2" />
- <plugin id="org.eclipse.equinox.ds" autoStart="true" startLevel="2" />
- <plugin id="org.eclipse.equinox.p2.reconciler.dropins" autoStart="true" startLevel="4" />
- <plugin id="org.eclipse.equinox.simpleconfigurator" autoStart="true" startLevel="1" />
- <plugin id="org.eclipse.update.configurator" autoStart="true" startLevel="4" />
- <property name="org.eclipse.update.reconcile" value="false" />
- </configurations>
-
-</product>
+plugins\org.eclipse.equinox.launcher_1.1.1.R36x_v20101122_1400.jar</programArgsWin>
+ <vmArgs>-XX:PermSize=512M -XX:MaxPermSize=512M -Xms40m -Xmx512m</vmArgs>
+ <vmArgsMac>-XstartOnFirstThread -Dorg.eclipse.swt.internal.carbon.smallFonts</vmArgsMac>
+ </launcherArgs>
+
+ <windowImages i16="/org.eclipse.koneki.ldt.branding/icons/LDT_16.png" i32="/org.eclipse.koneki.ldt.branding/icons/LDT_32.png" i64="/org.eclipse.koneki.ldt.branding/icons/LDT_64.png" i128="/org.eclipse.koneki.ldt.branding/icons/LDT_128.png"/>
+
+ <splash
+ location="org.eclipse.koneki.ldt.branding"
+ startupProgressRect="3,281,493,14"
+ startupMessageRect="7,260,350,20"
+ startupForegroundColor="D4BAA9" />
+ <launcher name="LuaDevelopmentTools">
+ <linux icon="../../../../plugins/org.eclipse.koneki.ldt.branding/icons/ldt.xpm"/>
+ <macosx icon="../../../../plugins/org.eclipse.koneki.ldt.branding/icons/ldt.icns"/>
+ <solaris/>
+ <win useIco="true">
+ <ico path="../../../../plugins/org.eclipse.koneki.ldt.branding/icons/ldt.ico"/>
+ <bmp/>
+ </win>
+ </launcher>
+
+ <vm>
+ </vm>
+
+ <plugins>
+ </plugins>
+
+ <features>
+ <feature id="org.eclipse.koneki.ldt.product" version="0.9.0.qualifier"/>
+ <feature id="org.eclipse.koneki.ldt.remote" version="0.9.0.qualifier"/>
+ <feature id="org.eclipse.rse"/>
+ <feature id="org.eclipse.rse.scp"/>
+ </features>
+
+ <configurations>
+ <plugin id="org.eclipse.core.runtime" autoStart="true" startLevel="4" />
+ <plugin id="org.eclipse.equinox.common" autoStart="true" startLevel="2" />
+ <plugin id="org.eclipse.equinox.ds" autoStart="true" startLevel="2" />
+ <plugin id="org.eclipse.equinox.p2.reconciler.dropins" autoStart="true" startLevel="4" />
+ <plugin id="org.eclipse.equinox.simpleconfigurator" autoStart="true" startLevel="1" />
+ <plugin id="org.eclipse.update.configurator" autoStart="true" startLevel="4" />
+ <property name="org.eclipse.update.reconcile" value="false" />
+ </configurations>
+
+</product>
View
63 target-platform/ldt.target
@@ -1,31 +1,32 @@
-<?xml version="1.0" encoding="UTF-8" standalone="no"?>
-<?pde version="3.8"?>
-
-<target name="Lua Development Tools" sequenceNumber="20">
-<locations>
-<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="planner" includeSource="false" type="InstallableUnit">
-<unit id="org.apache.commons.io" version="1.4.0.v20081110-1000"/>
-<unit id="org.apache.commons.io.source" version="1.4.0.v20081110-1000"/>
-<unit id="org.junit" version="4.8.1.v4_8_1_v20100427-1100"/>
-<unit id="org.junit.source" version="4.8.1.v4_8_1_v20100427-1100"/>
-<repository location="http://download.eclipse.org/tools/orbit/downloads/drops/repository"/>
-</location>
-<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="planner" includeSource="false" type="InstallableUnit">
-<unit id="org.eclipse.platform.sdk" version="4.2.0.I20120608-1400"/>
-<repository location="http://download.eclipse.org/releases/juno"/>
-</location>
-<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="planner" includeSource="false" type="InstallableUnit">
-<unit id="org.eclipse.dltk.core.sdk.feature.group" version="4.0.0.201206120848"/>
-<unit id="org.eclipse.dltk.itcl.sdk.feature.group" version="4.0.0.201206120848"/>
-<unit id="org.eclipse.dltk.javascript.sdk.feature.group" version="4.0.0.201206120848"/>
-<unit id="org.eclipse.dltk.mylyn.sdk.feature.group" version="4.0.0.201206120848"/>
-<unit id="org.eclipse.dltk.python.sdk.feature.group" version="4.0.0.201206120848"/>
-<unit id="org.eclipse.dltk.tcl.sdk.feature.group" version="4.0.0.201206120848"/>
-<repository location="http://download.eclipse.org/technology/dltk/updates-dev/4.0-stable/"/>
-</location>
-<location includeAllPlatforms="false" includeConfigurePhase="false" includeMode="planner" includeSource="false" type="InstallableUnit">
-<unit id="org.eclipse.rse.sdk.feature.group" version="3.4.0.201205300905-7U7UFBV7lfbwaIHTQX71hXj27ViO"/>
-<repository location="http://download.eclipse.org/tm/updates/3.4/"/>
-</location>
-</locations>
-</target>
+<?xml version="1.0" encoding="UTF-8" standalone="no"?>
+<?pde version="3.6"?>
+
+<target name="Lua Development Tools" sequenceNumber="21">
+<locations>
+<location includeAllPlatforms="false" includeMode="planner" includeSource="false" type="InstallableUnit">
+<unit id="org.apache.commons.io" version="1.4.0.v20081110-1000"/>
+<unit id="org.apache.commons.io.source" version="1.4.0.v20081110-1000"/>
+<unit id="org.junit" version="4.8.1.v4_8_1_v20100427-1100"/>
+<unit id="org.junit.source" version="4.8.1.v4_8_1_v20100427-1100"/>
+<repository location="http://download.eclipse.org/tools/orbit/downloads/drops/repository"/>
+</location>
+<location includeAllPlatforms="false" includeMode="planner" includeSource="false" type="InstallableUnit">
+<unit id="org.eclipse.platform.sdk" version="4.2.0.I20120608-1400"/>
+<repository location="http://download.eclipse.org/releases/juno"/>
+</location>
+<location includeAllPlatforms="false" includeMode="planner" includeSource="false" type="InstallableUnit">
+<unit id="org.eclipse.dltk.core.sdk.feature.group" version="4.0.0.201206120848"/>
+<unit id="org.eclipse.dltk.itcl.sdk.feature.group" version="4.0.0.201206120848"/>
+<unit id="org.eclipse.dltk.javascript.sdk.feature.group" version="4.0.0.201206120848"/>
+<unit id="org.eclipse.dltk.mylyn.sdk.feature.group" version="4.0.0.201206120848"/>
+<unit id="org.eclipse.dltk.python.sdk.feature.group" version="4.0.0.201206120848"/>
+<unit id="org.eclipse.dltk.tcl.sdk.feature.group" version="4.0.0.201206120848"/>
+<repository location="http://download.eclipse.org/technology/dltk/updates-dev/4.0-stable/"/>
+</location>
+<location includeAllPlatforms="false" includeMode="planner" includeSource="false" type="InstallableUnit">
+<unit id="org.eclipse.rse.sdk.feature.group" version="3.4.0.201205300905-7U7UFBV7lfbwaIHTQX71hXj27ViO"/>
+<unit id="org.eclipse.rse.scp.feature.group" version="0.2.0.201205300905-13-773573D933L3D"/>
+<repository location="http://download.eclipse.org/tm/updates/3.4/"/>
+</location>
+</locations>
+</target>
Please sign in to comment.
Something went wrong with that request. Please try again.