New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

misleading error message when connecting with password flag but no user flag #1015

Closed
tabascoeye opened this Issue Nov 5, 2018 · 3 comments

Comments

Projects
None yet
3 participants
@tabascoeye

tabascoeye commented Nov 5, 2018

Due to an error in my client, I connected to mosquitto 1.4.12 with connect flags:

Connect Flags: 0x6e, Password Flag, Will Retain, QoS Level: At least once delivery (Acknowledged deliver), Will Flag, Clean Session Flag
    0... .... = User Name Flag: Not set
    .1.. .... = Password Flag: Set

and the payload also only containing a password, no username.

Mosquitto yields some unspecific "socket error on client" and instantly closes the connection with FIN,ACK.
This could at least yield some better error message like "password set but no username" or something.

@tabascoeye

This comment has been minimized.

tabascoeye commented Nov 5, 2018

error message is:

New connection from 192.168.0.16 on port 1883.
Socket error on client (unknown), disconnecting.

ralight added a commit that referenced this issue Nov 7, 2018

@ralight ralight added this to the 1.5.4 milestone Nov 7, 2018

@ralight

This comment has been minimized.

Contributor

ralight commented Nov 7, 2018

Thanks for the report, an error message is given now. This will be in 1.5.4 shortly.

@ralight ralight closed this Nov 7, 2018

@karlp

This comment has been minimized.

Contributor

karlp commented Nov 7, 2018

if we're going to break out explicit cases like this, there's lots more that could be covered too....

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment