New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

_GNU_SOURCE needed for EAI_INPROGRESS #933

Closed
wants to merge 1 commit into
base: fixes
from

Conversation

Projects
None yet
2 participants
@bkuhls
Contributor

bkuhls commented Aug 24, 2018

Define of _GNU_SOURCE is needed to be able to use EAI_INPROGRESS in
loop.c.

This patch fixes a build error

loop.c:334:17: error: ‘EAI_INPROGRESS’ undeclared (first use in this function)
if(rc == EAI_INPROGRESS){

occuring with a glibc-2.27-based buildroot toolchain for sparc64

Target: sparc64-buildroot-linux-gnu
[...]
gcc version 6.4.0 (Buildroot 2018.05)

Source of the toolchain:
http://autobuild.buildroot.org/toolchains/tarballs/br-sparc64-full-2018.05.tar.bz2

Signed-off-by: Bernd Kuhls bernd.kuhls@t-online.de

  • If you are contributing a new feature, is your work based off the develop branch?
  • If you are contributing a bugfix, is your work based off the fixes branch?
  • Have you added an explanation of what your changes do and why you'd like us to include them?
  • Have you successfully run make test with your changes locally?
  • Have you signed the Eclipse Contributor Agreement, using the same email address as you used in your commits?
  • Do each of your commits have a "Signed-off-by" line, with the correct email address? Use "git commit -s" to generate this line for you.

_GNU_SOURCE needed for EAI_INPROGRESS
Define of _GNU_SOURCE is needed to be able to use EAI_INPROGRESS in
loop.c.

This patch fixes a build error

loop.c:334:17: error: ‘EAI_INPROGRESS’ undeclared (first use in this function)
        if(rc == EAI_INPROGRESS){

occuring with a glibc-2.27-based buildroot toolchain for sparc64

Target: sparc64-buildroot-linux-gnu
[...]
gcc version 6.4.0 (Buildroot 2018.05)

Source:
http://autobuild.buildroot.org/toolchains/tarballs/br-sparc64-full-2018.05.tar.bz2
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
@bkuhls

This comment has been minimized.

Contributor

bkuhls commented Aug 24, 2018

This patch also fixes the problem mentioned in #862

@ralight ralight added this to the 1.5.4 milestone Nov 6, 2018

@ralight

This comment has been minimized.

Contributor

ralight commented Nov 6, 2018

I've merged this manually to fix a conflict, so will close this now. Thanks for reporting and fixing this issue, it will be part of 1.5.4 shortly.

@ralight ralight closed this Nov 6, 2018

buildroot-auto-update pushed a commit to buildroot/buildroot that referenced this pull request Nov 9, 2018

mosquitto: security bump to version 1.5.4
>From the announcement:

When using a TLS enabled websockets listener with require_certificate
enabled, the mosquitto broker does not correctly verify client certificates.
This is now fixed.  All other security measures operate as expected, and in
particular non-websockets listeners are not affected by this.

https://mosquitto.org/blog/2018/11/version-154-released/

Drop patch 0001, now applied upstream:
eclipse/mosquitto#933

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment