Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

SPARQL query with cyrillic chars does not work in Workbench #391

Open
jeenbroekstra opened this issue Sep 7, 2016 · 0 comments
Labels

Comments

@jeenbroekstra
Copy link
Contributor

@jeenbroekstra jeenbroekstra commented Sep 7, 2016

(Migrated from https://openrdf.atlassian.net/browse/SES-2069)

(Reporting on behalf of Venelin @ Ontotext)

The Workbench does not appear to process queries with Cyrillic characters correctly.

Here is the scenario to reproduce :

1/ Insert following triple using Sesame Workbench
{code}
INSERT DATA {
<a:subject1> <a:has_title> "Μια φορά" .
}
{code}

2/ Verify that triple is stored correctly : verification passes OK - title is returned with correct encoding in Workbench

{code}
SELECT * {
?subject <a:has_title> ?title
}
{code}
3/ Execute a regex query - which returns no results, which is the problem

{code}
SELECT DISTINCT ?uuid ?label WHERE{
?uuid <a:has_title> ?label.
FILTER regex(str(?label), "Μια φορά", "i") .
}
{code}

When doing this same experiment using the commandline console instead of workbench, the query returns the expected result - so this seems to indicate that the problem is in how the Workbench encoded the query.

As an aside: I should point out that I have tried the workaround solution mentioned here: http://openrdf.callimachus.net/sesame/2.7/docs/articles/serverinstall.docbook?view#workbench-utf-8 for POST requests, but it made no difference.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
2 participants
You can’t perform that action at this time.