Permalink
Browse files

Do not use org.hamcrest aggregation bundle.

org.hamcrest bundle is simply requiring and reexporting all org.hamcrest.* bundles.
This commit adds requires/imports on the exact bundles so the aggregating org.hamcrest bundle can be not used at all

Signed-off-by: Mickael Istria <mistria@redhat.com>
  • Loading branch information...
1 parent 2ae015a commit 68e86da42008fb428dd4f37ee0544c6a3239d1ea @akurtakov akurtakov committed with mickaelistria Aug 2, 2012
View
4 org.eclipse.swtbot.eclipse.finder.test/META-INF/MANIFEST.MF
@@ -11,7 +11,9 @@ Require-Bundle: org.eclipse.jface.text,
org.eclipse.core.runtime,
org.eclipse.swtbot.swt.finder,
org.eclipse.swtbot.eclipse.finder,
- org.hamcrest,
+ org.hamcrest.core,
+ org.hamcrest.library,
+ org.hamcrest.integration,
org.junit4,
org.apache.log4j;bundle-version="[1.2.13,1.3.0)",
org.eclipse.swtbot.junit4_x,
View
2 org.eclipse.swtbot.eclipse.finder/META-INF/MANIFEST.MF
@@ -29,6 +29,6 @@ Import-Package: javax.swing.text,
org.osgi.framework;version="1.4.0"
Require-Bundle: org.eclipse.swtbot.swt.finder;visibility:=reexport,
org.hamcrest.core;bundle-version="1.1.0",
- org.hamcrest;bundle-version="1.1.0",
+ org.hamcrest.library;bundle-version="1.1.0",
org.eclipse.ui;bundle-version="3.6.0",
org.eclipse.ui.editors;bundle-version="3.6.0"
View
2 org.eclipse.swtbot.eclipse.gef.finder/META-INF/MANIFEST.MF
@@ -29,4 +29,4 @@ Import-Package: org.apache.log4j;version="[1.2.13,1.3.0)",
Require-Bundle: org.eclipse.swtbot.eclipse.finder;visibility:=reexport,
org.eclipse.ui.workbench;bundle-version="3.6.0",
org.hamcrest.core;bundle-version="1.1.0",
- org.hamcrest;bundle-version="1.1.0"
+ org.hamcrest.library;bundle-version="1.1.0"
View
2 org.eclipse.swtbot.eclipse.gef/feature.xml
@@ -35,7 +35,7 @@
<import plugin="org.eclipse.ui.ide"/>
<import plugin="org.eclipse.swtbot.swt.finder"/>
<import plugin="org.eclipse.swtbot.eclipse.finder"/>
- <import plugin="org.hamcrest"/>
+ <import plugin="org.hamcrest.core"/>
<import plugin="org.apache.log4j"/>
</requires>
View
4 org.eclipse.swtbot.eclipse.ui.test/META-INF/MANIFEST.MF
@@ -6,4 +6,6 @@ Bundle-Version: 2.1.0.qualifier
Bundle-Vendor: Eclipse.org - SWTBot
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Fragment-Host: org.eclipse.swtbot.eclipse.ui
-Require-Bundle: org.eclipse.swtbot.go
+Require-Bundle: org.eclipse.swtbot.go,
+ org.hamcrest.library,
+ org.hamcrest.integration
View
2 org.eclipse.swtbot.eclipse/feature.xml
@@ -40,7 +40,7 @@
<import plugin="org.eclipse.swt"/>
<import plugin="org.eclipse.ui.workbench"/>
<import plugin="org.eclipse.ui"/>
- <import plugin="org.hamcrest"/>
+ <import plugin="org.hamcrest.core"/>
<import plugin="org.eclipse.ui.editors"/>
<import plugin="org.eclipse.swtbot.swt.finder"/>
<import plugin="org.eclipse.swtbot.junit4_x"/>
View
2 org.eclipse.swtbot.forms.finder.test/META-INF/MANIFEST.MF
@@ -10,7 +10,7 @@ Require-Bundle: org.eclipse.swt,
org.eclipse.swtbot.swt.finder,
org.apache.log4j;bundle-version="[1.2.13,1.3.0)",
org.junit4,
- org.hamcrest,
+ org.hamcrest.core,
org.eclipse.swtbot.junit4_x,
org.eclipse.swtbot.forms.finder,
org.eclipse.ui.forms,
View
2 org.eclipse.swtbot.forms/feature.xml
@@ -34,7 +34,7 @@
<import plugin="org.eclipse.ui"/>
<import plugin="org.eclipse.ui.ide"/>
<import plugin="org.eclipse.swtbot.swt.finder"/>
- <import plugin="org.hamcrest"/>
+ <import plugin="org.hamcrest.core"/>
<import plugin="org.apache.log4j"/>
</requires>
View
4 org.eclipse.swtbot.generator.test/META-INF/MANIFEST.MF
@@ -5,7 +5,9 @@ Bundle-SymbolicName: org.eclipse.swtbot.generator.test
Bundle-Version: 2.1.0.qualifier
Bundle-RequiredExecutionEnvironment: J2SE-1.5
Require-Bundle: org.eclipse.swtbot.swt.finder,
- org.hamcrest,
+ org.hamcrest.core,
+ org.hamcrest.integration,
+ org.hamcrest.library,
org.junit4,
org.eclipse.swtbot.generator,
org.eclipse.ui
View
2 org.eclipse.swtbot.go/META-INF/MANIFEST.MF
@@ -7,7 +7,7 @@ Require-Bundle: org.eclipse.swtbot.eclipse.core;visibility:=reexport,
org.eclipse.swtbot.eclipse.finder;visibility:=reexport,
org.eclipse.swtbot.swt.finder;visibility:=reexport,
org.eclipse.swtbot.junit4_x;visibility:=reexport,
- org.hamcrest;visibility:=reexport,
+ org.hamcrest.core;visibility:=reexport,
org.junit4;visibility:=reexport,
org.eclipse.core.runtime;visibility:=reexport,
org.apache.log4j;visibility:=reexport,
View
4 org.eclipse.swtbot.swt.finder.test/META-INF/MANIFEST.MF
@@ -8,7 +8,9 @@ Require-Bundle: org.eclipse.swt,
org.eclipse.swt.examples,
org.eclipse.swtbot.swt.finder,
org.apache.log4j;bundle-version="[1.2.13,1.3.0)",
- org.hamcrest,
+ org.hamcrest.core,
+ org.hamcrest.library,
+ org.hamcrest.integration,
org.eclipse.swtbot.junit4_x,
org.junit;bundle-version="[4.8.0,5.0.0)"
Bundle-ActivationPolicy: lazy
View
3 org.eclipse.swtbot.swt.finder/META-INF/MANIFEST.MF
@@ -30,4 +30,5 @@ Import-Package: junit.framework;version="4.5.0",
org.eclipse.swt.widgets,
org.junit;version="4.5.0"
Require-Bundle: org.hamcrest.core;bundle-version="1.1.0",
- org.hamcrest;bundle-version="1.1.0"
+ org.hamcrest.library;bundle-version="1.1.0",
+ org.hamcrest.integration;bundle-version="1.1.0"
View
2 org.eclipse.swtbot.test/feature.xml
@@ -46,7 +46,7 @@
<import plugin="org.eclipse.swtbot.swt.finder"/>
<import plugin="org.apache.log4j"/>
<import plugin="org.junit4"/>
- <import plugin="org.hamcrest"/>
+ <import plugin="org.hamcrest.core"/>
<import plugin="org.eclipse.swtbot.junit4_x"/>
<import plugin="org.eclipse.ui"/>
<import plugin="org.eclipse.jface.text"/>
View
7 org.eclipse.swtbot/feature.xml
@@ -49,13 +49,6 @@
unpack="false"/>
<plugin
- id="org.hamcrest"
- download-size="0"
- install-size="0"
- version="0.0.0"
- unpack="false"/>
-
- <plugin
id="org.hamcrest.core"
download-size="0"
install-size="0"

0 comments on commit 68e86da

Please sign in to comment.