Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

225694 Invalid dependancies in JSDT feature

  • Loading branch information...
commit 792748bd5f8ad455cc5a4341473f140db24fb754 1 parent 5877317
david_williams authored
View
18 features/org.eclipse.wst.jsdt_tests.feature/feature.xml
@@ -22,16 +22,14 @@
</url>
<requires>
- <import plugin="org.eclipse.core.resources"/>
- <import plugin="org.eclipse.core.runtime"/>
- <import plugin="org.eclipse.wst.jsdt.core"/>
- <import plugin="org.junit"/>
- <import plugin="org.eclipse.core.resources" version="3.2.0" match="compatible"/>
- <import plugin="org.eclipse.core.runtime" version="3.2.0" match="compatible"/>
- <import plugin="org.junit" version="3.8.1" match="compatible"/>
- <import plugin="org.eclipse.team.core" version="3.2.0" match="compatible"/>
- <import plugin="org.eclipse.text" version="3.2.0" match="compatible"/>
- <import plugin="com.ibm.icu" version="3.4.4" match="compatible"/>
+ <import plugin="org.eclipse.core.resources" version="3.4.0" match="compatible"/>
+ <import plugin="org.eclipse.core.runtime" version="3.4.0" match="compatible"/>
+ <import plugin="org.eclipse.wst.jsdt.core" version="1.0.0" match="compatible"/>
+ <import plugin="org.junit" version="3.8.2" match="compatible"/>
+ <import plugin="org.eclipse.wst.jsdt.core.tests.compiler" version="1.0.0" match="compatible"/>
+ <import plugin="org.eclipse.team.core" version="3.3.100" match="compatible"/>
+ <import plugin="org.eclipse.text" version="3.4.0" match="compatible"/>
+ <import plugin="com.ibm.icu" version="3.8.1" match="compatible"/>
</requires>
<plugin
View
8 tests/org.eclipse.wst.jsdt.core.tests.compiler/META-INF/MANIFEST.MF
@@ -5,10 +5,10 @@ Bundle-SymbolicName: org.eclipse.wst.jsdt.core.tests.compiler; singleton:=true
Bundle-Version: 1.0.0.qualifier
Bundle-Vendor: %providerName
Bundle-Localization: plugin
-Require-Bundle: org.eclipse.core.resources,
- org.eclipse.core.runtime,
- org.eclipse.wst.jsdt.core,
- org.junit
+Require-Bundle: org.eclipse.core.resources;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.wst.jsdt.core;bundle-version="[1.0.0,2.0.0)",
+ org.junit;bundle-version="[3.8.2,4.0.0)"
Export-Package: org.eclipse.wst.jsdt.core.tests.compiler,
org.eclipse.wst.jsdt.core.tests.compiler.parser,
org.eclipse.wst.jsdt.core.tests.compiler.regression,
View
16 tests/org.eclipse.wst.jsdt.core.tests.model/META-INF/MANIFEST.MF
@@ -12,13 +12,13 @@ Export-Package: org.eclipse.wst.jsdt.core.tests,
org.eclipse.wst.jsdt.core.tests.model,
org.eclipse.wst.jsdt.core.tests.rewrite.describing,
org.eclipse.wst.jsdt.core.tests.rewrite.modifying
-Require-Bundle: org.eclipse.core.resources;bundle-version="[3.2.0,4.0.0)",
- org.eclipse.core.runtime;bundle-version="[3.2.0,4.0.0)",
- org.junit;bundle-version="[3.8.1,4.0.0)",
- org.eclipse.wst.jsdt.core.tests.compiler,
- org.eclipse.team.core;bundle-version="[3.2.0,4.0.0)",
- org.eclipse.text;bundle-version="[3.2.0,4.0.0)",
- com.ibm.icu;bundle-version="[3.4.4,4.0.0)",
- org.eclipse.wst.jsdt.core
+Require-Bundle: org.eclipse.core.resources;bundle-version="[3.4.0,4.0.0)",
+ org.eclipse.core.runtime;bundle-version="[3.4.0,4.0.0)",
+ org.junit;bundle-version="[3.8.2,4.0.0)",
+ org.eclipse.wst.jsdt.core.tests.compiler;bundle-version="[1.0.0,2.0.0)",
+ org.eclipse.team.core;bundle-version="[3.3.100,4.0.0)",
+ org.eclipse.text;bundle-version="[3.4.0,4.0.0)",
+ com.ibm.icu;bundle-version="[3.8.1,4.0.0)",
+ org.eclipse.wst.jsdt.core;bundle-version="[1.0.0,2.0.0)"
Eclipse-LazyStart: true
Bundle-RequiredExecutionEnvironment: J2SE-1.4
Please sign in to comment.
Something went wrong with that request. Please try again.