Hey, I've added Ruby 1.9.2 support.
The problem was with the right_aws version you were using. I'm just requiring a version >= than the 2.1.0.
I'm also requiring 'digest/md5' explicitly (the problem with your code is loading that)
Thanks for this!
Nicolás Hock Isaza
Use a ruby 1.9.2 compatible right_aws gem (2.10.0)
Version bump to 1.0.0
Use right_aws >= 2.1.0 and require digest/md5. Should make it ruby 1.…