Skip to content

issue with custom taxonomy in media overlay #1

Closed
stvwlf opened this Issue Dec 14, 2012 · 1 comment

2 participants

@stvwlf
stvwlf commented Dec 14, 2012

Hi Eddie - been working with your plugin for possible use on client project. I started with ver 1.4, in a test install of WP 3.5. I saw there were some formatting issues so I located this 1.5 beta version you are working on.

When using the standard Category taxonomy it is working just as you described.

But I am trying to use a hierarchical custom taxonomy and getting different results with it. (My custom taxonomy is working perfectly in the Media Library, page, so I know it is correct).

When I add
add_filter('mc_taxonomy', 'mwd_mc_filter_taxonomy');
function mwd_mc_filter_taxonomy($taxonomy) {
if ( $taxonomy == 'category' ) {
$taxonomy = 'clip';
}
return $taxonomy;
}
to functions.php, the plugin line that displays the taxonomy name and the down arrow to its right is appearing. However nothing happens when I click the down arrow. Also, the WP default taxonomy tag-like entry field appears above it (it is correctly displaying the two terms this test image is assigned to) When I switch to the WP default Category taxonomy, clicking the down arrow does display the category terms, and the default media overlay single taxonomy entry field is hidden.

To summarize, the 1.5 plugin version works correctly with the default WP Category taxonomy but seems to not be working correctly with a custom taxonomy.

@eddiemoya
Owner

Thanks for bringing this up. With my rush to get this out the door I completely forgot to come back and rest custom taxonomies. I'll be working on this today.

@eddiemoya eddiemoya was assigned Dec 14, 2012
@eddiemoya eddiemoya added a commit that closed this issue Dec 15, 2012
@eddiemoya changing the css and most of the javascript for the modal metabox to …
…accomodate any taxonomy. Now makes use of the Backbone.js Media API components in 3.5. fixes #1 thanks @stvwlf for the bug report.
22931a7
@eddiemoya eddiemoya closed this in 22931a7 Dec 15, 2012
@eddiemoya eddiemoya added the Complete label Mar 28, 2014
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.