New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Rules defined for filenames with a leading . are not loaded #114

Closed
iamFIREcracker opened this Issue Nov 25, 2018 · 2 comments

Comments

Projects
None yet
2 participants
@iamFIREcracker
Copy link

iamFIREcracker commented Nov 25, 2018

Rules defined for filenames with a leading . are not loaded up by the plugin.

My .editorconfig:

[*]
indent_size = 2
tab_width = 2

[.vimrc]
indent_size = 4
tab_width = 4

When I edit my .vimrc file, and run verbose set shiftwidth I get the following:

  shiftwidth=2
        Last set from ~/my-env/dotfiles/.vim/pack/bundle/start/vim-editorconfig/autoload/editorconfig/indent_size.vim line 16

With the following .editorconfig instead (no more .):

[*]
indent_size = 2
tab_width = 2

[vimrc]
indent_size = 4
tab_width = 4

settings are loaded up just fine:

  shiftwidth=4
        Last set from ~/my-env/dotfiles/.vim/pack/bundle/start/vim-editorconfig/autoload/editorconfig/indent_size.vim line 16

Is this expected?

@xuhdev xuhdev changed the title .vimrc rules not being used Rules defined for filenames with a leading . are not loaded Nov 25, 2018

@xuhdev

This comment has been minimized.

Copy link
Member

xuhdev commented Nov 25, 2018

What's your value of g:EditorConfig_core_mode?

@iamFIREcracker

This comment has been minimized.

Copy link

iamFIREcracker commented Jan 13, 2019

Apologies @xuhdev, but I did not see your reply...

...and even bigger apologies, I did not realize I filed this to the wrong project: editorconfig-vim vs vim-editorconfig...

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment