meta helper doesn't work #11

Closed
benhanks040888 opened this Issue Dec 13, 2012 · 2 comments

Comments

Projects
None yet
2 participants
@benhanks040888
// controller
$this->twiggy->meta('description', 'description');

// twig
{{ meta }}

When I view the source, it generates blank row.

I debug it up to the point of this line

private function _load()
{
    $this->_globals['meta'] = $this->_compile_metadata();
    $this->_rendered = TRUE;

    return $this->_twig->loadTemplate($this->_template . $this->_config['template_file_ext']);
}

and when I var_dump the $this->_globals['meta'], the description meta is still there.

Any idea? Thanks

@edmundask

This comment has been minimized.

Show comment Hide comment
@edmundask

edmundask Dec 14, 2012

Owner

Hi there,

sorry for not responding to this sooner, have been busy. :)

Yes, this seems to be a bug. At the moment I can't test it, but I'm pretty sure that instead of

$this->_globals['meta'] = $this->_compile_metadata();

there should be

$this->set('meta', $this->_compile_metadata(), true);

See if this works.

Owner

edmundask commented Dec 14, 2012

Hi there,

sorry for not responding to this sooner, have been busy. :)

Yes, this seems to be a bug. At the moment I can't test it, but I'm pretty sure that instead of

$this->_globals['meta'] = $this->_compile_metadata();

there should be

$this->set('meta', $this->_compile_metadata(), true);

See if this works.

@edmundask edmundask closed this in 60cdc55 Dec 15, 2012

@benhanks040888

This comment has been minimized.

Show comment Hide comment
@benhanks040888

benhanks040888 Dec 16, 2012

thanks!

thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment