New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Dispatch 0.10.0 support #210

Closed
eed3si9n opened this Issue Apr 30, 2013 · 2 comments

Comments

Projects
None yet
2 participants
@eed3si9n
Owner

eed3si9n commented Apr 30, 2013

original

reported by @polymorphic as Support for dispatch 0.10.0 in sbt-scalaxb?

I'm upgrading to dispatch 0.10.0 (http://notes.implicit.ly/post/47436559635/dispatch-0-10-0) and doing so requires the generated service code to import Defaults._ in addition to dispatch._. Doing so provides the implicit ExecutionContext, without which the generated code doesn't compile. What are the plans for making sbt-scalaxb compatible with dispatch 0.10.0? Meanwhile what's the recommended way of providing the implicit ExecutionContext to the X_dispatch.scala generated code?

expectation

provide dispatchVersion key to generate cake for Dispatch 0.10.0.

@eed3si9n eed3si9n closed this in 21a082f Apr 30, 2013

@eed3si9n

This comment has been minimized.

Show comment
Hide comment
@eed3si9n

eed3si9n Apr 30, 2013

Owner

@martiell I added a new key.

Owner

eed3si9n commented Apr 30, 2013

@martiell I added a new key.

@polymorphic

This comment has been minimized.

Show comment
Hide comment
@polymorphic

polymorphic Apr 30, 2013

Great, thanks for the fast turnaround!

Great, thanks for the fast turnaround!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment