New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

fix for Soap11Fault bug when empty detail #450

Merged
merged 1 commit into from Nov 12, 2017

Conversation

Projects
None yet
2 participants
@dportabella
Contributor

dportabella commented Nov 8, 2017

About issue #449

the bug was here:

case class Soap11Fault[+A](original: Any, detail: Option[A], headers: scala.xml.NodeSeq) extends Exception {
  println(s"+++ Soap11Fault:\n  original: $original\n  detail: $detail\n  headers:$headers")   // I added this
  def asFault[B: scalaxb.XMLFormat]: Soap11Fault[B] = Soap11Fault(original, detail map {
    case x: soapenvelope11.Detail => x.any.head.value match {

in my case, the web server was returning this info:

+++ Soap11Fault:
  original: Fault({http://schemas.xmlsoap.org/soap/envelope/}Server,(SEE0001) Session identifier cookie value cannot be null or an empty string - It is required that the high level Web service client program participate in the session initialized by the server.,None,Some(Detail(List(),ListMap())))
  detail: Some(Detail(List(),ListMap()))
  headers:

so, calling x.any.head is a bug.

@dportabella

This comment has been minimized.

Show comment
Hide comment
@dportabella

dportabella Nov 9, 2017

Contributor

I try to compile this buf fix for the sbt-scalaxb plugin for Scala 0.12, but it fails.
Any idea?

$ git clone git@github.com:dportabella/scalaxb.git
$ cd scalaxb
$ git checkout fix
$ sbt "+ publishLocal"

[info] Loading global plugins from /Users/david/.sbt/0.13/plugins
[info] Loading project definition from /private/tmp/ii/scalaxb/project
[info] Set current project to root (in build file:/private/tmp/ii/scalaxb/)
[info] Setting version to 2.11.11
[info] Reapplying settings...
[info] Set current project to root (in build file:/private/tmp/ii/scalaxb/)
[info] Packaging /private/tmp/ii/scalaxb/sbt-scalaxb/target/scala-2.11/sbt-0.13/sbt-scalaxb-1.5.2-sources.jar ...
[info] Updating {file:/private/tmp/ii/scalaxb/}scalaxbPlugin...
[info] Done packaging.
[info] Wrote /private/tmp/ii/scalaxb/cli/target/scala-2.11/scalaxb_2.11-1.5.2.pom
[info] Resolving org.scala-sbt#sbt-launch;0.13.16 ...
[info] Done updating.
[info] :: delivering :: org.scalaxb#scalaxb_2.11;1.5.2 :: 1.5.2 :: release :: Thu Nov 09 16:55:16 CET 2017
[info] 	delivering ivy file to /private/tmp/ii/scalaxb/cli/target/scala-2.11/ivy-1.5.2.xml
[info] Wrote /private/tmp/ii/scalaxb/sbt-scalaxb/target/scala-2.11/sbt-0.13/sbt-scalaxb-1.5.2.pom
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/poms/scalaxb_2.11.pom
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/poms/scalaxb_2.11.pom.sha1
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/poms/scalaxb_2.11.pom.md5
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[info] 	published scalaxb_2.11 to /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/poms/scalaxb_2.11.pom
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/jars/scalaxb_2.11.jar
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[info] Main Scala API documentation to /private/tmp/ii/scalaxb/sbt-scalaxb/target/scala-2.11/sbt-0.13/api...
[info] Compiling 3 Scala sources to /private/tmp/ii/scalaxb/sbt-scalaxb/target/scala-2.11/sbt-0.13/classes...
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/jars/scalaxb_2.11.jar.sha1
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/jars/scalaxb_2.11.jar.md5
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[info] 	published scalaxb_2.11 to /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/jars/scalaxb_2.11.jar
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/srcs/scalaxb_2.11-sources.jar
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/srcs/scalaxb_2.11-sources.jar.sha1
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/srcs/scalaxb_2.11-sources.jar.md5
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[info] 	published scalaxb_2.11 to /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/srcs/scalaxb_2.11-sources.jar
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/docs/scalaxb_2.11-javadoc.jar
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/docs/scalaxb_2.11-javadoc.jar.sha1
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/docs/scalaxb_2.11-javadoc.jar.md5
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[info] 	published scalaxb_2.11 to /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/docs/scalaxb_2.11-javadoc.jar
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/ivys/ivy.xml
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/ivys/ivy.xml.sha1
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/ivys/ivy.xml.md5
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[info] 	published ivy to /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/ivys/ivy.xml
[info] :: delivering :: org.scalaxb#integration_2.11;1.5.2 :: 1.5.2 :: release :: Thu Nov 09 16:55:16 CET 2017
[info] 	delivering ivy file to /private/tmp/ii/scalaxb/integration/target/scala-2.11/ivy-1.5.2.xml
[info] :: delivering :: org.scalaxb#sbt-scalaxb;1.5.2 :: 1.5.2 :: release :: Thu Nov 09 16:55:16 CET 2017
[info] 	delivering ivy file to /private/tmp/ii/scalaxb/sbt-scalaxb/target/scala-2.11/sbt-0.13/ivy-1.5.2.xml
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/integration_2.11/1.5.2/ivys/ivy.xml
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/integration_2.11/1.5.2/ivys/ivy.xml.sha1
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/integration_2.11/1.5.2/ivys/ivy.xml.md5
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[info] 	published ivy to /Users/david/.ivy2/local/org.scalaxb/integration_2.11/1.5.2/ivys/ivy.xml
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:9: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:9: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxb                 = taskKey[Seq[File]]("Generates case classes and typeclass instances")
[error]   lazy val scalaxb                 = taskKey[Seq[File]]("Generates case classes and typeclass instances")
[error]                                                         ^
[error]                                                         ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:10: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:10: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGenerate         = taskKey[Seq[File]]("Generates case classes and typeclass instances")
[error]   lazy val scalaxbGenerate         = taskKey[Seq[File]]("Generates case classes and typeclass instances")
[error]                                                         ^
[error]                                                         ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:11: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:11: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbConfig           = settingKey[ScConfig]("Configuration for scalaxb")
[error]   lazy val scalaxbConfig           = settingKey[ScConfig]("Configuration for scalaxb")
[error]                                                           ^
[error]                                                           ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:12: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:12: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbXsdSource        = settingKey[File]("xsd source directory")
[error]   lazy val scalaxbXsdSource        = settingKey[File]("xsd source directory")
[error]                                                       ^
[error]                                                       ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:13: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:13: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbWsdlSource       = settingKey[File]("wsdl source directory")
[error]   lazy val scalaxbWsdlSource       = settingKey[File]("wsdl source directory")
[error]                                                       ^
[error]                                                       ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:14: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:14: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbPackageName      = settingKey[String]("Specifies the target package")
[error]                                                         ^
[error]   lazy val scalaxbPackageName      = settingKey[String]("Specifies the target package")
[error]                                                         ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:15: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbPackageNames     = settingKey[Map[URI, String]]("specifies the target package")
[error]                                                                   ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:16: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbAutoPackages     = settingKey[Boolean]("Generates packages for different namespaces automatically")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:15: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:17: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbPackageNames     = settingKey[Map[URI, String]]("specifies the target package")
[error]   lazy val scalaxbClassPrefix      = settingKey[Option[String]]("Prefixes generated class names")
[error]                                                                   ^
[error]                                                                 ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:18: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:16: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbParamPrefix      = settingKey[Option[String]]("Prefixes generated parameter names")
[error]   lazy val scalaxbAutoPackages     = settingKey[Boolean]("Generates packages for different namespaces automatically")
[error]                                                                 ^
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:17: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:19: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbClassPrefix      = settingKey[Option[String]]("Prefixes generated class names")
[error]                                                                 ^
[error]   lazy val scalaxbAttributePrefix  = settingKey[Option[String]]("Prefixes generated attribute parameters")
[error]                                                                 ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:20: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:18: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbOpOutputWrapperPostfix = settingKey[String]("Postfixes operation output wrapper names (default: Output)")
[error]   lazy val scalaxbParamPrefix      = settingKey[Option[String]]("Prefixes generated parameter names")
[error]                                                               ^
[error]                                                                 ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:21: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:19: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbPrependFamily    = settingKey[Boolean]("Prepends family name to class names")
[error]   lazy val scalaxbAttributePrefix  = settingKey[Option[String]]("Prefixes generated attribute parameters")
[error]                                                          ^
[error]                                                                 ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:20: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:22: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbWrapContents     = settingKey[Seq[String]]("Wraps inner contents into a separate case class")
[error]                                                              ^
[error]   lazy val scalaxbOpOutputWrapperPostfix = settingKey[String]("Postfixes operation output wrapper names (default: Output)")
[error]                                                               ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:23: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:21: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbContentsSizeLimit = settingKey[Int]("Defines long contents to be segmented (default: max)")
[error]   lazy val scalaxbPrependFamily    = settingKey[Boolean]("Prepends family name to class names")
[error]                                                          ^
[error]                                                       ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:24: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbChunkSize        = settingKey[Int]("Segments long sequences into chunks (default: 10)")
[error]                                                      ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:22: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbWrapContents     = settingKey[Seq[String]]("Wraps inner contents into a separate case class")
[error]                                                              ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:25: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbNamedAttributes  = settingKey[Boolean]("Generates named fields for attributes")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:23: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbContentsSizeLimit = settingKey[Int]("Defines long contents to be segmented (default: max)")
[error]                                                       ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:26: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbPackageDir       = settingKey[Boolean]("Generates package directories")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:24: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbChunkSize        = settingKey[Int]("Segments long sequences into chunks (default: 10)")
[error]                                                      ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:27: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGenerateRuntime  = settingKey[Boolean]("Generates scalaxb runtime (scalaxb.scala)")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:25: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:28: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbNamedAttributes  = settingKey[Boolean]("Generates named fields for attributes")
[error]   lazy val scalaxbProtocolFileName = settingKey[String]("Protocol file name (xmlprotocol.scala)")
[error]                                                          ^
[error]                                                         ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:26: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbPackageDir       = settingKey[Boolean]("Generates package directories")
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:29: can't expand macros compiled by previous versions of Scala
[error]                                                          ^
[error]   lazy val scalaxbProtocolPackageName  = settingKey[Option[String]]("Package for protocols")
[error]                                                                     ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:27: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGenerateRuntime  = settingKey[Boolean]("Generates scalaxb runtime (scalaxb.scala)")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:30: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGenerateMutable  = settingKey[Boolean]("Generates mutable classes")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:28: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbProtocolFileName = settingKey[String]("Protocol file name (xmlprotocol.scala)")
[error]                                                         ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:31: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGenerateVisitor  = settingKey[Boolean]("Generates visitor")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:29: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbProtocolPackageName  = settingKey[Option[String]]("Package for protocols")
[error]                                                                     ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:32: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbLaxAny           = settingKey[Boolean]("Relaxes namespace constraints of xs:any")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:30: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGenerateMutable  = settingKey[Boolean]("Generates mutable classes")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:33: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbCombinedPackageNames = settingKey[Map[Option[String], Option[String]]]("")
[error]                                                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:31: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGenerateVisitor  = settingKey[Boolean]("Generates visitor")
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:34: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGenerateDispatchClient = settingKey[Boolean]("Generate of Dispatch client")
[error]                                                          ^
[error]                                                                ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:35: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGenerateDispatchAs = settingKey[Boolean]("Generates Dispatch \"as\"")
[error]                                                            ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:32: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbLaxAny           = settingKey[Boolean]("Relaxes namespace constraints of xs:any")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:36: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGenerateGigahorseClient = settingKey[Boolean]("Generate of Gigahorse client")
[error]                                                                 ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:33: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:37: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbCombinedPackageNames = settingKey[Map[Option[String], Option[String]]]("")
[error]   lazy val scalaxbGenerateSingleClient = settingKey[HttpClientType.Value]("Generate a single client (one of Dispatch or Gigahorse)")
[error]                                                                                          ^
[error]                                                                           ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:38: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbDispatchVersion  = settingKey[String]("Dispatch version")
[error]                                                         ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:34: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGenerateDispatchClient = settingKey[Boolean]("Generate of Dispatch client")
[error]                                                                ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:39: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGigahorseVersion = settingKey[String]("Gigahorse version")
[error]                                                         ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:35: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGenerateDispatchAs = settingKey[Boolean]("Generates Dispatch \"as\"")
[error]                                                            ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:40: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGigahorseBackend = settingKey[GigahorseHttpBackend.Value]("Gigahorse http backend")
[error]                                                                             ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:36: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGenerateGigahorseClient = settingKey[Boolean]("Generate of Gigahorse client")
[error]                                                                 ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:41: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbAsync            = settingKey[Boolean]("Generates async SOAP client")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:42: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbIgnoreUnknown    = settingKey[Boolean]("Ignores unknown Elements")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:37: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGenerateSingleClient = settingKey[HttpClientType.Value]("Generate a single client (one of Dispatch or Gigahorse)")
[error]                                                                           ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:43: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbVararg           = settingKey[Boolean]("Uses varargs when possible. (default: false)")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:38: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbDispatchVersion  = settingKey[String]("Dispatch version")
[error]                                                         ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:39: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGigahorseVersion = settingKey[String]("Gigahorse version")
[error]                                                         ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:40: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGigahorseBackend = settingKey[GigahorseHttpBackend.Value]("Gigahorse http backend")
[error]                                                                             ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:41: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbAsync            = settingKey[Boolean]("Generates async SOAP client")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:42: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbIgnoreUnknown    = settingKey[Boolean]("Ignores unknown Elements")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:43: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbVararg           = settingKey[Boolean]("Uses varargs when possible. (default: false)")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbPlugin.scala:36: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbPlugin.scala:36: can't expand macros compiled by previous versions of Scala
[error]     logLevel in scalaxb := (logLevel?? Level.Info).value
[error]                                     ^
[error]     logLevel in scalaxb := (logLevel?? Level.Info).value
[error]                                     ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbPlugin.scala:49: can't expand macros compiled by previous versions of Scala
[error]       val outdir = sourceManaged.value
[error]                    ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbPlugin.scala:49: can't expand macros compiled by previous versions of Scala
[error]       val outdir = sourceManaged.value
[error]                    ^
[info] No documentation generated with unsuccessful compiler run
[error] 37 errors found
[error] 37 errors found
[error] (scalaxbPlugin/compile:doc) Scaladoc generation failed
[error] (scalaxbPlugin/compile:compileIncremental) Compilation failed
[error] Total time: 5 s, completed Nov 9, 2017 4:55:19 PM
Contributor

dportabella commented Nov 9, 2017

I try to compile this buf fix for the sbt-scalaxb plugin for Scala 0.12, but it fails.
Any idea?

$ git clone git@github.com:dportabella/scalaxb.git
$ cd scalaxb
$ git checkout fix
$ sbt "+ publishLocal"

[info] Loading global plugins from /Users/david/.sbt/0.13/plugins
[info] Loading project definition from /private/tmp/ii/scalaxb/project
[info] Set current project to root (in build file:/private/tmp/ii/scalaxb/)
[info] Setting version to 2.11.11
[info] Reapplying settings...
[info] Set current project to root (in build file:/private/tmp/ii/scalaxb/)
[info] Packaging /private/tmp/ii/scalaxb/sbt-scalaxb/target/scala-2.11/sbt-0.13/sbt-scalaxb-1.5.2-sources.jar ...
[info] Updating {file:/private/tmp/ii/scalaxb/}scalaxbPlugin...
[info] Done packaging.
[info] Wrote /private/tmp/ii/scalaxb/cli/target/scala-2.11/scalaxb_2.11-1.5.2.pom
[info] Resolving org.scala-sbt#sbt-launch;0.13.16 ...
[info] Done updating.
[info] :: delivering :: org.scalaxb#scalaxb_2.11;1.5.2 :: 1.5.2 :: release :: Thu Nov 09 16:55:16 CET 2017
[info] 	delivering ivy file to /private/tmp/ii/scalaxb/cli/target/scala-2.11/ivy-1.5.2.xml
[info] Wrote /private/tmp/ii/scalaxb/sbt-scalaxb/target/scala-2.11/sbt-0.13/sbt-scalaxb-1.5.2.pom
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/poms/scalaxb_2.11.pom
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/poms/scalaxb_2.11.pom.sha1
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/poms/scalaxb_2.11.pom.md5
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[info] 	published scalaxb_2.11 to /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/poms/scalaxb_2.11.pom
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/jars/scalaxb_2.11.jar
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[info] Main Scala API documentation to /private/tmp/ii/scalaxb/sbt-scalaxb/target/scala-2.11/sbt-0.13/api...
[info] Compiling 3 Scala sources to /private/tmp/ii/scalaxb/sbt-scalaxb/target/scala-2.11/sbt-0.13/classes...
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/jars/scalaxb_2.11.jar.sha1
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/jars/scalaxb_2.11.jar.md5
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[info] 	published scalaxb_2.11 to /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/jars/scalaxb_2.11.jar
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/srcs/scalaxb_2.11-sources.jar
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/srcs/scalaxb_2.11-sources.jar.sha1
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/srcs/scalaxb_2.11-sources.jar.md5
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[info] 	published scalaxb_2.11 to /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/srcs/scalaxb_2.11-sources.jar
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/docs/scalaxb_2.11-javadoc.jar
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/docs/scalaxb_2.11-javadoc.jar.sha1
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/docs/scalaxb_2.11-javadoc.jar.md5
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[info] 	published scalaxb_2.11 to /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/docs/scalaxb_2.11-javadoc.jar
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/ivys/ivy.xml
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/ivys/ivy.xml.sha1
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/ivys/ivy.xml.md5
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[info] 	published ivy to /Users/david/.ivy2/local/org.scalaxb/scalaxb_2.11/1.5.2/ivys/ivy.xml
[info] :: delivering :: org.scalaxb#integration_2.11;1.5.2 :: 1.5.2 :: release :: Thu Nov 09 16:55:16 CET 2017
[info] 	delivering ivy file to /private/tmp/ii/scalaxb/integration/target/scala-2.11/ivy-1.5.2.xml
[info] :: delivering :: org.scalaxb#sbt-scalaxb;1.5.2 :: 1.5.2 :: release :: Thu Nov 09 16:55:16 CET 2017
[info] 	delivering ivy file to /private/tmp/ii/scalaxb/sbt-scalaxb/target/scala-2.11/sbt-0.13/ivy-1.5.2.xml
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/integration_2.11/1.5.2/ivys/ivy.xml
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/integration_2.11/1.5.2/ivys/ivy.xml.sha1
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[warn] Attempting to overwrite /Users/david/.ivy2/local/org.scalaxb/integration_2.11/1.5.2/ivys/ivy.xml.md5
[warn] 	This usage is deprecated and will be removed in sbt 1.0.
[info] 	published ivy to /Users/david/.ivy2/local/org.scalaxb/integration_2.11/1.5.2/ivys/ivy.xml
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:9: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:9: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxb                 = taskKey[Seq[File]]("Generates case classes and typeclass instances")
[error]   lazy val scalaxb                 = taskKey[Seq[File]]("Generates case classes and typeclass instances")
[error]                                                         ^
[error]                                                         ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:10: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:10: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGenerate         = taskKey[Seq[File]]("Generates case classes and typeclass instances")
[error]   lazy val scalaxbGenerate         = taskKey[Seq[File]]("Generates case classes and typeclass instances")
[error]                                                         ^
[error]                                                         ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:11: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:11: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbConfig           = settingKey[ScConfig]("Configuration for scalaxb")
[error]   lazy val scalaxbConfig           = settingKey[ScConfig]("Configuration for scalaxb")
[error]                                                           ^
[error]                                                           ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:12: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:12: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbXsdSource        = settingKey[File]("xsd source directory")
[error]   lazy val scalaxbXsdSource        = settingKey[File]("xsd source directory")
[error]                                                       ^
[error]                                                       ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:13: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:13: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbWsdlSource       = settingKey[File]("wsdl source directory")
[error]   lazy val scalaxbWsdlSource       = settingKey[File]("wsdl source directory")
[error]                                                       ^
[error]                                                       ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:14: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:14: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbPackageName      = settingKey[String]("Specifies the target package")
[error]                                                         ^
[error]   lazy val scalaxbPackageName      = settingKey[String]("Specifies the target package")
[error]                                                         ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:15: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbPackageNames     = settingKey[Map[URI, String]]("specifies the target package")
[error]                                                                   ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:16: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbAutoPackages     = settingKey[Boolean]("Generates packages for different namespaces automatically")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:15: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:17: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbPackageNames     = settingKey[Map[URI, String]]("specifies the target package")
[error]   lazy val scalaxbClassPrefix      = settingKey[Option[String]]("Prefixes generated class names")
[error]                                                                   ^
[error]                                                                 ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:18: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:16: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbParamPrefix      = settingKey[Option[String]]("Prefixes generated parameter names")
[error]   lazy val scalaxbAutoPackages     = settingKey[Boolean]("Generates packages for different namespaces automatically")
[error]                                                                 ^
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:17: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:19: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbClassPrefix      = settingKey[Option[String]]("Prefixes generated class names")
[error]                                                                 ^
[error]   lazy val scalaxbAttributePrefix  = settingKey[Option[String]]("Prefixes generated attribute parameters")
[error]                                                                 ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:20: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:18: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbOpOutputWrapperPostfix = settingKey[String]("Postfixes operation output wrapper names (default: Output)")
[error]   lazy val scalaxbParamPrefix      = settingKey[Option[String]]("Prefixes generated parameter names")
[error]                                                               ^
[error]                                                                 ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:21: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:19: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbPrependFamily    = settingKey[Boolean]("Prepends family name to class names")
[error]   lazy val scalaxbAttributePrefix  = settingKey[Option[String]]("Prefixes generated attribute parameters")
[error]                                                          ^
[error]                                                                 ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:20: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:22: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbWrapContents     = settingKey[Seq[String]]("Wraps inner contents into a separate case class")
[error]                                                              ^
[error]   lazy val scalaxbOpOutputWrapperPostfix = settingKey[String]("Postfixes operation output wrapper names (default: Output)")
[error]                                                               ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:23: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:21: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbContentsSizeLimit = settingKey[Int]("Defines long contents to be segmented (default: max)")
[error]   lazy val scalaxbPrependFamily    = settingKey[Boolean]("Prepends family name to class names")
[error]                                                          ^
[error]                                                       ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:24: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbChunkSize        = settingKey[Int]("Segments long sequences into chunks (default: 10)")
[error]                                                      ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:22: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbWrapContents     = settingKey[Seq[String]]("Wraps inner contents into a separate case class")
[error]                                                              ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:25: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbNamedAttributes  = settingKey[Boolean]("Generates named fields for attributes")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:23: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbContentsSizeLimit = settingKey[Int]("Defines long contents to be segmented (default: max)")
[error]                                                       ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:26: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbPackageDir       = settingKey[Boolean]("Generates package directories")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:24: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbChunkSize        = settingKey[Int]("Segments long sequences into chunks (default: 10)")
[error]                                                      ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:27: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGenerateRuntime  = settingKey[Boolean]("Generates scalaxb runtime (scalaxb.scala)")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:25: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:28: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbNamedAttributes  = settingKey[Boolean]("Generates named fields for attributes")
[error]   lazy val scalaxbProtocolFileName = settingKey[String]("Protocol file name (xmlprotocol.scala)")
[error]                                                          ^
[error]                                                         ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:26: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbPackageDir       = settingKey[Boolean]("Generates package directories")
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:29: can't expand macros compiled by previous versions of Scala
[error]                                                          ^
[error]   lazy val scalaxbProtocolPackageName  = settingKey[Option[String]]("Package for protocols")
[error]                                                                     ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:27: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGenerateRuntime  = settingKey[Boolean]("Generates scalaxb runtime (scalaxb.scala)")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:30: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGenerateMutable  = settingKey[Boolean]("Generates mutable classes")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:28: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbProtocolFileName = settingKey[String]("Protocol file name (xmlprotocol.scala)")
[error]                                                         ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:31: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGenerateVisitor  = settingKey[Boolean]("Generates visitor")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:29: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbProtocolPackageName  = settingKey[Option[String]]("Package for protocols")
[error]                                                                     ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:32: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbLaxAny           = settingKey[Boolean]("Relaxes namespace constraints of xs:any")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:30: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGenerateMutable  = settingKey[Boolean]("Generates mutable classes")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:33: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbCombinedPackageNames = settingKey[Map[Option[String], Option[String]]]("")
[error]                                                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:31: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGenerateVisitor  = settingKey[Boolean]("Generates visitor")
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:34: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGenerateDispatchClient = settingKey[Boolean]("Generate of Dispatch client")
[error]                                                          ^
[error]                                                                ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:35: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGenerateDispatchAs = settingKey[Boolean]("Generates Dispatch \"as\"")
[error]                                                            ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:32: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbLaxAny           = settingKey[Boolean]("Relaxes namespace constraints of xs:any")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:36: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGenerateGigahorseClient = settingKey[Boolean]("Generate of Gigahorse client")
[error]                                                                 ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:33: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:37: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbCombinedPackageNames = settingKey[Map[Option[String], Option[String]]]("")
[error]   lazy val scalaxbGenerateSingleClient = settingKey[HttpClientType.Value]("Generate a single client (one of Dispatch or Gigahorse)")
[error]                                                                                          ^
[error]                                                                           ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:38: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbDispatchVersion  = settingKey[String]("Dispatch version")
[error]                                                         ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:34: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGenerateDispatchClient = settingKey[Boolean]("Generate of Dispatch client")
[error]                                                                ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:39: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGigahorseVersion = settingKey[String]("Gigahorse version")
[error]                                                         ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:35: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGenerateDispatchAs = settingKey[Boolean]("Generates Dispatch \"as\"")
[error]                                                            ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:40: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGigahorseBackend = settingKey[GigahorseHttpBackend.Value]("Gigahorse http backend")
[error]                                                                             ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:36: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGenerateGigahorseClient = settingKey[Boolean]("Generate of Gigahorse client")
[error]                                                                 ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:41: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbAsync            = settingKey[Boolean]("Generates async SOAP client")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:42: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbIgnoreUnknown    = settingKey[Boolean]("Ignores unknown Elements")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:37: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGenerateSingleClient = settingKey[HttpClientType.Value]("Generate a single client (one of Dispatch or Gigahorse)")
[error]                                                                           ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:43: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbVararg           = settingKey[Boolean]("Uses varargs when possible. (default: false)")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:38: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbDispatchVersion  = settingKey[String]("Dispatch version")
[error]                                                         ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:39: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGigahorseVersion = settingKey[String]("Gigahorse version")
[error]                                                         ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:40: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbGigahorseBackend = settingKey[GigahorseHttpBackend.Value]("Gigahorse http backend")
[error]                                                                             ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:41: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbAsync            = settingKey[Boolean]("Generates async SOAP client")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:42: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbIgnoreUnknown    = settingKey[Boolean]("Ignores unknown Elements")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbKeys.scala:43: can't expand macros compiled by previous versions of Scala
[error]   lazy val scalaxbVararg           = settingKey[Boolean]("Uses varargs when possible. (default: false)")
[error]                                                          ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbPlugin.scala:36: can't expand macros compiled by previous versions of Scala
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbPlugin.scala:36: can't expand macros compiled by previous versions of Scala
[error]     logLevel in scalaxb := (logLevel?? Level.Info).value
[error]                                     ^
[error]     logLevel in scalaxb := (logLevel?? Level.Info).value
[error]                                     ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbPlugin.scala:49: can't expand macros compiled by previous versions of Scala
[error]       val outdir = sourceManaged.value
[error]                    ^
[error] /private/tmp/ii/scalaxb/sbt-scalaxb/src/main/scala/sbtscalaxb/ScalaxbPlugin.scala:49: can't expand macros compiled by previous versions of Scala
[error]       val outdir = sourceManaged.value
[error]                    ^
[info] No documentation generated with unsuccessful compiler run
[error] 37 errors found
[error] 37 errors found
[error] (scalaxbPlugin/compile:doc) Scaladoc generation failed
[error] (scalaxbPlugin/compile:compileIncremental) Compilation failed
[error] Total time: 5 s, completed Nov 9, 2017 4:55:19 PM
@eed3si9n

This comment has been minimized.

Show comment
Hide comment
@eed3si9n

eed3si9n Nov 12, 2017

Owner

Not sure. Probably you have to line up Scala version (2.10 for sbt 0.13) to compile sbt plugin.

Owner

eed3si9n commented Nov 12, 2017

Not sure. Probably you have to line up Scala version (2.10 for sbt 0.13) to compile sbt plugin.

@eed3si9n eed3si9n merged commit 0782eae into eed3si9n:master Nov 12, 2017

1 check passed

continuous-integration/travis-ci/pr The Travis CI build passed
Details
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment