Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Support unstable node, but not 0.5.4.

0.5.4 is just a little _too_ unstable.
  • Loading branch information...
commit c9c3c8e67f3284013ba7e70347dc98230e59aba3 1 parent acf893a
@eee-c authored
Showing with 16 additions and 10 deletions.
  1. +13 −9 INSTALL.md
  2. +2 −0  README.md
  3. +1 −1  package.json
View
22 INSTALL.md
@@ -1,7 +1,7 @@
INSTALL express-spdy
====================
-These instructions will install edge-openssl, edge-node.js and express-spdy in your home directory. This will *not* overwrite or affect any system libraries.
+These instructions will install edge-openssl, unstable node.js and express-spdy in your home directory. This will *not* overwrite or affect any system libraries.
I work with tarballs in `$HOME/src` and source code controlled code in `$HOME/repos`.
@@ -47,19 +47,23 @@ After configuring openssl, build and install it:
make
make install
-Edge node.js
-------------
+Unstable node.js
+----------------
+
+*NOTE: do NOT use node 0.5.4!!!*
-Install the source code in `$HOME/repos`:
+Install the source code in `$HOME/src`:
- mkdir $HOME/repos
- cd $HOME/repos/
- git clone https://github.com/joyent/node.git
- cd node
+ mkdir -p $HOME/src
+ cd $HOME/src/
+ # NOTE: check for latest version at http://nodejs.org/#download
+ wget http://nodejs.org/dist/v0.5.4/node-v0.5.3.tar.gz
+ tar zxf node-v0.5.3.tar.gz
+ cd node-v0.5.3
Configure node to use edge-openssl and to install locally:
- ./configure --openssl-includes=$HOME/local/include --openssl-libpath=$HOME/local/lib --prefix=$HOME/local/node-v0.5.0-pre
+ ./configure --openssl-includes=$HOME/local/include --openssl-libpath=$HOME/local/lib --prefix=$HOME/local/node-v0.5.3
make
make install
View
2  README.md
@@ -17,6 +17,8 @@ Install the latest snapshot of openssl with NPN and shared objects. Currently (
Install node.js 0.5.0-pre or later. Currently (6/21/2011), this requires installing node from the master repository (0.4.8 will _not_ work).
+*NOTE: this will NEVER work on node 0.5.4!!! (will support 0.5.5 when available)*
+
With the npn-enabled node, `npm install express-spdy`.
Detailed instructions in [INSTALL.md](https://github.com/eee-c/express-spdy/blob/master/INSTALL.md).
View
2  package.json
@@ -10,7 +10,7 @@
},
"main": "index.js",
"engines": {
- "node": ">= 0.5.0-pre"
+ "node": ">= 0.5.0-pre < 0.5.4"
},
"dependencies": {
"express-unstable": ">= 2.3.11",
Please sign in to comment.
Something went wrong with that request. Please try again.