Permalink
Browse files

Fix usage of SSL_CIPHER_description() under OpenSSL ver < 0.9.8m-beta1 (

#720)

Patch by: michaelortmann

OpenSSL changed API for SSL_CIPHER_description()
This fixes a compiler warning for OpenSSL version < 0.9.8m-beta1
  • Loading branch information...
michaelortmann authored and vanosg committed Nov 1, 2018
1 parent 82bd496 commit 02461491dccb49647fe2fbfe844e5847c6ac0e05
Showing with 4 additions and 1 deletion.
  1. +4 −1 src/tls.c
@@ -627,7 +627,10 @@ void ssl_info(SSL *ssl, int where, int ret)
X509 *cert;
char buf[256];
ssl_appdata *data;
const SSL_CIPHER *cipher;
#if OPENSSL_VERSION_NUMBER >= 0x009080d1L /* 0.9.8m-beta1 */
const
#endif
SSL_CIPHER *cipher;
int secret, processed;
if (!(data = (ssl_appdata *) SSL_get_app_data(ssl)))

0 comments on commit 0246149

Please sign in to comment.