Skip to content

TypeError: expected bytes, bytearray or buffer compatible object #38

Closed
mhurron opened this Issue Jul 28, 2013 · 0 comments

1 participant

@mhurron
mhurron commented Jul 28, 2013

Running nodeenv into a virtualenv targeting Python 3.3.2 dies with the following:

$ nodeenv --version
Traceback (most recent call last):
File "/home/sbrown/workspace/homesite/bin/nodeenv", line 9, in
load_entry_point('nodeenv==0.6.6', 'console_scripts', 'nodeenv')()
File "/home/sbrown/workspace/homesite/lib/python3.3/site-packages/nodeenv.py", line 501, in main
opt, args = parse_args()
File "/home/sbrown/workspace/homesite/lib/python3.3/site-packages/nodeenv.py", line 79, in parse_args
metavar='NODE_VER', default=get_last_stable_node_version(),
File "/home/sbrown/workspace/homesite/lib/python3.3/site-packages/nodeenv.py", line 480, in get_last_stable_node_version
return p.stdout.readline().replace("\n", "")
TypeError: expected bytes, bytearray or buffer compatible object

$ python -V
Python 3.3.2

@ekalinin ekalinin closed this in 5b0d770 Jul 29, 2013
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.