Skip to content


Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Direct Rails 3.1 users more explicitly toward Squeel

  • Loading branch information...
commit a616a174f188375908f0c78fbf24ce17693c498a 1 parent 24e6cc8
@ernie ernie authored
4 Gemfile
@@ -1,8 +1,8 @@
source ""
-gem 'arel', :git => 'git://', :tag => 'v2.0.8.beta.20110131120940'
-git 'git://', :branch => '3-0-stable' do
+gem 'arel', :git => 'git://'
+git 'git://' do
gem 'activesupport'
gem 'activerecord'
7 README.rdoc
@@ -1,11 +1,12 @@
= MetaWhere
-(If you're using edge Rails and you'd like to help me test the successor to
-MetaWhere, please have a look at {Squeel}[])
MetaWhere puts the power of Arel predications (comparison methods) in your ActiveRecord
condition hashes.
+== Using Rails 3.1?
+You want to take a look at {Squeel}[] instead.
== Why?
<b>I hate SQL fragments in Rails code.</b> Resorting to <tt>where('name LIKE ?', '%something%')</tt> is an admission of defeat. It says, "I concede to allow your rigid, 1970's-era syntax into my elegant Ruby world of object oriented goodness." While sometimes such concessions are necessary, they should <em>always</em> be a last resort, because <b>once you move away from an abstract representation of your intended query, your query becomes more brittle.</b> You're now reduced to hacking about with regular expressions, string scans, and the occasional deferred variable interpolation trick (like '#{quoted_table_name}') in order to maintain some semblance of flexibility.
2  lib/meta_where/version.rb
@@ -1,3 +1,3 @@
module MetaWhere
- VERSION = "1.0.4"
+ VERSION = "1.1.0.pre"
5 meta_where.gemspec
@@ -35,9 +35,8 @@ you're feeling especially appreciative. It'd help me justify this
s.rubyforge_project = "meta_where"
- s.add_dependency 'activerecord', '~> 3.0.0'
- s.add_dependency 'activesupport', '~> 3.0.0'
- s.add_dependency 'arel', '~> 2.0.7'
+ s.add_dependency 'activerecord', '~> 3.1.0.alpha'
+ s.add_dependency 'activesupport', '~> 3.1.0.alpha'
s.add_development_dependency 'shoulda'
s.add_development_dependency 'sqlite3', '~> 1.3.3'
Please sign in to comment.
Something went wrong with that request. Please try again.